Monterey 12.3 beta 4 FIXED problem that crept in with 12.2 where video in Mimo no longer working! (M1 Max 64GB only!)


Hi there! I just updated to 12.2 and MimoLive has stopped working - video preview not showing, screen sharing not working and the camera live syphon I use with my DSLR not working.

You can see in this screenshot:
1 Bottom left is the content video playing here
2 Above that Media Player is blank instead of preview
3 Top right Program Output Black instead of video output.

Any advice would be much appreciated! Maybe I’ve done something wrong but all i did was update to 12.2. MimoLive was working perfectly before.

Here is a loom showing the issue Loom | Free Screen & Video Recording Software

Here is another Loom showing OBS is working with Syphon/Camera Live - it also shows MimoLive Facetime camera shows in Content/Video Source but not the preview or output. The DSLR (Camera Live via Syphon) doesnt even show in the Content/Video Source preview but is working in OBS as you can see. Hope this helps!

I have tried this with MimoLive 5.11, 6.0b6 and the latest 6.0b8.

Hi @Nick_Booker That is very strange. I have two Macs here (Intel and M1) with 12.2 and both work fine.

Can you please send me the document via DropBox, WeTransfer or the like?

Also, can you please make a new document with just that video source and just one Placer to see if that works with a fresh document?

Will test with doc. Should have thought to do that.

And report back with my doc.

Thank you Oliver

OK I created a new doc with just Facetime Camera and Syphon/CameraLive/DSLR

Same problem! Content/VideoSource shows preview but notihign in the main Placer Preview or in Program Output.

Screen Source doesnt work properly either - it shows in the Content/Video Source but not the Preview or Output AND the “Show Capture Area” is greyed out saying origin 0x0???

Screenshot 2022-01-28 at 4.42.33 PM

OBS is working normal. Screen share, virtual camera output and syphon/cameralive/Dslr.

So it does appear to be something to do with MimoLive (and not my doc as we’ve tried a new clean doc).

Hi @Nick_Booker Thanks for taking the time to do all that testing! Much appreciated. Now, we just have to find out what’s going on as we do not see any of this on our test machines.

Can you please send me the System Report of your machine? And can you confirm you tested this with 5.11 and 6.0b8? (Those would be the two benchmarks. 5.11 was built before macOS 12 and 6.0b8 was built with macOS 12, so at least 6.0b8 needs to work.)

Thank you for your cooperation and patience.

I have emailed you the System Report and can confirm I am using 6.0b8 and also tried 5.11.

Thanks Oliver. I have a show on Sunday night so very much hoping you can help me find the solution. I dont know what else to try.

Hi @Oliver_Boinx I have the same problem since the update to 12.2 with beta versions 6.0b8 and 6.0b5. With version 5.11 I also have the problem. Version 6.0b6 did not run for me - crashed immediately.

My system:
MacBook Pro (16" 2021)
Chip Apple M1 Max
Memory 64GB

Oliver has been INCREDIBLY helpful and patient with me today. Trying to figure out what is happening.

Very interesting that you have same issue.

Have you got any version of mimolive working on 12.2? If so which one?

We are now trying clean install of 12.2 off a separate startup disk. Tried reinstall Monterey and that didn’t work.

I have now replaced the MacBook Pro with my Mac mini M1 - which also runs 12.2. I don’t have the problems on the Mac mini. I use the same setup and the same mimolive files. Camera etc. are connected via Thunderbolt. That is really strange. I’ll see if I can find the difference between my Mac mini and MacBook Pro - they’re actually set up identically.

Did you manage to get any version of mimo to work on 12.2 max?

No, none of the versions I tested worked. I have installed the beta of 12.3 and have the problem there too. So I will probably make a clean install.

I have the problem not only with video as a source. It also affects other layer types. Maybe the info helps to narrow down the cause.

Same. Please do let us know if clean install works. I can’t do that until tomorrow at the earliest.

Good luck!

3 hours and a clean install later I can say that the problems are unfortunately not fixed. I have only installed mimolive and nothing else. But with both version 5 and 6 I still have the error.

Mimolive 5.x

Mimolive 6.x Beta

I am sorry you are facing this but I must admit am slightly relieved it isn’t just me.

Oliver and Achim will no doubt crack this one!

I am going to hold off doing a clean install if it didn’t work for you.

1 Like

Update on this issue:

Thanks to @Nick_Booker for paving the way for our documentation for reverting to 12.1, which involves installing macOS Monterey on an external drive.

Update - With 12.2 Beta 3 the problem is probably not fixed yet. Just tested briefly.

Interesting that it is one memory configuration (if I read this correctly). Any thoughts on why?

I bought the M1 MAX 64GB w/32 GPU to get away from hardware limitations when working with video.

Hope Apple can get this fixed before my next big event in April.

Thanks for testing! We think this beta is too soon after we discovered the issue.