How do I export & monitor the sound output from mimoLive?!

I have audio levels on the VU meters of sources, layers and Audio monitor but I can’t hear anything no matter how I set up the output in Apple System Prefs for Sound. Do I need to be running Loopback for this (I don’t own it) surely not?! Searching for documentation ATM. I always have this issue when I haven’t used mimoLive for a year or two… it’s so hard to figure out.

When I try and select a device, like headphone output or USB audio, there are no devices available to choose from. Weird.

Zoom has the Virtual Camera as a source for video no problems but no Audio. Why does this always happen to me? I’m on a new M1 Mac, not using the old MBP this used to happen on.

Did I mention I’m going live in a few hours? :zipper_mouth_face: I know the audio is in the program feed as I can see the VU meters and it will hopefully go via Virtual Camera to zoom but I need to be able to isolate audio channels for getting levels right and testing the microphones etc etc.

Apple Silicon version is in beta, and it’s a known issue (see release-notes). With your knowledge and understanding about all of this It should be very easy for you to download a fork of Blackhole to generate two virtual devices. One for IN and one for OUT. Yes, Plug-Ins, HAL. Please let us know the URL to your stream.

EDIT: I posted it separately, to have it as tip available:

How to use BlackHole instead of Loopback (free alternative)

1 Like

Had to abort mimoLive plans, again. I just did the intro sequence in mimoLive and used the Zoom app on the phone to do the broadcast. Bit of a disaster from my POV.

Thanks for the free audio routing software. I’ll check it out. Still want to know why mimoLive isn’t working, or is it just because it’s on M1 and a bug, or is it human-between-keyboard-and-mac?!

1 Like

Two devices, two results. In analogy: You cannot use an Input as an Output. At least not the same time.

The Apple System Prefs should not be an issue. This is to set for where the system plays audio. The mimoLive Audio Monitor output uses the device set there independently of the system settings.

When I try and select a device, like headphone output or USB audio, there are no devices available to choose from. Weird.

That is indeed very weird. Somehow, mimoLive isn’t able to detect audio output devices. Normally, I would say this is due to settings in “System Preferences → Security → Privacy” but there are no privacy settings for output devices.

You can try to use the mimoLive Debug Preferences to turn off magic device detection. Press the “Option” key when going to the mimoLive Menu. The “Preferences” item will turn into “Debug Preferences”. Select that and navigate to the “General” tab. Select the “Disable Magic Device Preferences” and try to see if the audio devices appear again.

Zoom has the Virtual Camera as a source for video no problems but no Audio. Why does this always happen to me? I’m on a new M1 Mac, not using the old MBP this used to happen on.

This is a known issue with 6.0b5 on M1. The workaround is to use Loopback or Blackhole while we work on the fix.

thanks. I did read that when I looked at the Beta release notes, but at that time I was intending to stream into our YouTube channel. Then somebody sent out an email to the membership with a scheduled Zoom meeting link. So I switched to Zoom but forgot that note about audio. I nearly tried Loopback (the free version which I could have reset every 20 minutes) but because I could not even get headphone output in mimoLive then I was confused as hell as to what is going on. Doubted myself and switched plans to just use Zoom directly with the iPhone camera and microphone.

Tried all that. No joy. Will restart the Mac mini and try again.

It’s weird that the M1 v6.0b5 bug is the same kind of problem I had on intel a major version or two back on mimoLive maybe a year ago. I was wondering if the document I have was something I opened and then retitled to use some of the components and that it inherited a bug from last year.

So I made a new mimoLive document from the Audio Podcast template and low and behold there was External Headphones as the selected audio output option. No other options available (no Mac mini speaker for example). I’ll plug my Entrance MixerFace R4 and test that as a destination later.

Then I made a new file with the mimoNews template and that had the Audio Monitor set to Built-In Output (unavailable). When I select External Headphones, the Built-In Output (unavailable) option disappears ad it cannot be selected again.

Now when I plug headphones in and try to listen the port is declared as “busy” External Headphones (busy). Too weird!

I created a fourth new document, another Audio Podcast template and headphones are available. Dragged an Audio Only Layer and— joy at last — it plays in my cans. (it’s very good to be able to drag layers between documents, this removes so much time and micro-friction, a FR I had for years Thx @Achim_Boinx and @Oliver_Boinx !!!).

I have no idea why the inconsistent results with headphones and the no option for Mac mini internal speaker.

My MixerFace R4 ( (the previous version to the one I linked to which they started selling this month) shows up in System Prefs… Audio output & input and I can listen to audio from output to it’s DAC.

MixerFace it is only periodically appearing in mimoLive as an output destination and gets a red warning that it dropped out even when it’s still connected. Most of theme it isn’t visible in mimoLive. Haven’t been able to get even one second of audio from mimoLive to Mixerface.

I rebooted the Mac mini again and it all seems to be working on the Audio Monitor panel via my MixerFace to headphones. Even with the most problematic tvshow. So that’s a relief!!

Next to test my wireless microphones coming in.

This sounds like mimoLive is removing devices from the list when they are disabled but doesn’t re-enable them when they become available again. Very strange. That is on macOS Monterey?

It seems to be that this is the same phenomenon I explored on M1mbAir: When I plug in a HDMI-out-usb-c-dongle, it sets the resolution to whatever, but it does not change the resolution of the output that I set under “displays”, till I reboot the macBook Air. After reboot, the latest settings are valid.

It seems to be a strange phenomenon caused by macOs. mbProM1 is not affected. But there are other weird things happening, like a stuttering web cam (which stops stuttering, as soon as I open FaceTime).

No this is on Big Sur. I had emailed Achim prior to asking on hear about why macOS to go with. Being a bit more conservative than yourself perhaps, Achim advised to stick with Big Sur for now. It actually took me the best part of an afternoon to revert to Big Sur because the Apple Support team lead me down the garden path and around the corner…

As FYI for those who want to regress their operating system on AS hardware in the future, the installer prevents you going from Monterey to Big Sur when you get a few steps into the install process.

The trick is you have to use Disk Utilities in recovery mode to erase the internal SSD, then install Big Sur. But Apple support staff being what they are didn’t know that and one of them got me to download Apple Configurator on my MBP and connect to the mini with a USB cable (which itself took 30 minutes of trial and error because the instructions in Apple’s documentation didn’t work) and try and install Big Sur like you would do a firmware update on an iPad. Well that didn’t 't work either. Eventually I got a hold of someone who knew what they were doing. Then I spend ~3 to 4 hours waiting for Migration Assistent to install my apps and settings from a Time Machine backup from a previous Mac mini I owned. The said “1 hour and 6 minutes to go…” for two hours so I aborted that and manually installed some of my apps and helper extensions etc etc.

Back up and restore on macOS using Time Machine and Migration Assistent is decidedly crap in my opinion. MA is a nice idea but what a time sink, and some of the stuff never comes over anyhow, while the bugs do come so I’m usually avoiding it.

:eyes: interesting….

one of the nice things about Mac mini M1 is that it only takes less than a minute to shutdown and restart the Mac even with several big apps running, they launch in no time at all. On my mid-2015 MBP 16 GB that could take up to 5 minutes or more, so when I was in hurry I was reluctant to restart the Mac, which is a valuable action in the troubleshooting tool kit.

Now I’ll have to retrain myself to restart often!

AND: The most weird thing: These phenomenons vanished on a second fresh created user account. :scream: I also had some nice conversations with apple support about this, and additionally, I wrote feedback to Apple about this.

On M1max, the stuttering webcam is also present. :joy:

can you film the stuttering and post it, I’m curious. It isn’t to do with LED/fluro lighting and framerates is it? you mean more like judder that is seen when you pan a film camera at 24 fps?

I have lighting issues but I’m pretty sure its a different phenomenon to your issue.

It’s more like every 5 to 7 seconds one frame. And it’s only in third party apps and never in FaceTime. And it’s only affecting Apple’s internal WebCams. It does not affect M1Air’s WebCam, only mbPro13m1’s and mbPro16inchM1max’s. :smiley: - as I can see, other models are not available for testing. And only, when the by the installer created user is logged in. :joy::joy::joy:

I think this is wasted time, to extra submit fiddle around with this.

Ok. I always have a “Mr Clean” user account to do A/B testing and so often problems don’t appear in the clean user account. macOS collects a lot of software flotsam and jetsam (junk).

1 Like