Need help: mimoLive sometimes doesn't recognize mp4 files half way through

Hi there.

I faced a trouble about play mp4 footage on mimoLive 5.10.1 on Mac mini with M1 chip.

I set up my template with some mp4 files for title animation, background movie, and main contents of my livestream.

When start up mimoLive with my template, it’s ok. All of footages are loaded, can play normal.

But, after few minutes, sometimes can’t play mp4 file footages. Footages on Sources panels with red light, but Layer properties can’t show movie thumbnail.

When it happens, I restart up mimoLive then temporary fix this problem, but same situation happens after few minutes.

I can’t say clearly how long passed after launched mimoLive, anyway this trouble happens almost 100% everytime.

I want to use mimoLive my livestream, but this is useless. Already pucheased long time, I hope to support this problem as possible as soon.

Unfortunately, I also wait for Apple Silicon support. Currently, I can just repeat what Boinx said in the last live stream: First official Apple Silicon Beta should come mid this year. M1 is currently not officially supported.

Now a work around “test”: When you use a pip layer instead of the placer. Does it work then?

what if you convert it to .mov?

Hi @JoPhi , thank you for your comment.

At first, I had some tests after my first post.

I did same settings on my MacBook Pro 2017 with Mojave, it happens same trouble.

And I did you suggested PIP layer, also doesn’t work. When it happens, all of footages registered at Sources panel cannot play at layers. Not specified one, all of them. This template consists four footages, one title logo animation, one background animation, two main contents films. When I notice this problem, all of footages are not playable on layer property panel.

Checked layers: Placer, Presenter 2D, PIP

Hi @JMVBMW, I realized with your comment.

Actually, my title logo animation is not mp4. It was necessary to attach alpha channel, so it’s .mov file.

So, the result was same. When I noticed this problem, all of footages includes .mov are not playable as I said last post.

I would like to update the information.

At my first post, I said “after few minutes”, to say accurate, I wonder it’s not correct.

When I start up mimoLive with my template, some layers or layer sets are switched, then I noticed that footages are not playable. During this time, a few minutes.

But, I cannot reproduce which layer turn on or turn off.

And one more update. I find out suspicious point that filenames are written in Japanese language. So there’re 2byte code. But, one title logo animation file of four footages, it name is “vi_AE.mov”. So this point is unlikely? FYI, the fullpath of the footage file includes the directory named Japanese language 2byte code.

Furthermore, this trouble occurs on both “Copied into document” and “Absolute path” references mode.

Thank you for the tests and the thoughts about it.

Sometimes I have file names which partially or only use the charset “Emoji” before the extension, so I never came to the idea that Katakana, Kanji or Hiragana could influence the behaviour. For real, I assumed that all charsets are based on utf-8 in macOS.

Could it be that the Background is simply not “looped”, or does it loop and suddenly not start? When you place the files inside a visible multiView, does it solve the troubles?

That’s very strange.

@JoPhi Thank you for your idea. I agree with you about filename of character set.

I checked play mode of footages.

  • title logo animation → Play Once
  • background animation → Loop
  • main contents in play list → any checkbox not checked

About Multiview. I tested several times, There footages would be black out on Multiview when this trouble happens.

I succeeded to reproduce this trouble and record video it!

1 Like

Thank you so much for the video.

@Achim_Boinx , could you please have a closer look on this phenomenon? It seems to be that somehow the connection between source and layer/multiView gets lost. Maybe because of the used charset (non-latin characters).

@kohki.shikata , could you please explain me, how you embedded the video here? I was never able to do so. :hugs:

@JoPhi Video embedding was easy. I uploaded my video to my youtube account, then the youtube url pasted here. After submitting, the forum convert to iframe video, I guess.

This forum does not like me. It never happened for me. :joy::joy::joy:. Thank you so much, I hope this phenomenon will be explained/solved/cleared soon.

1 Like

I find out something new!

This problem occurs when after Automation layer fires.

I set up automation layer that let opening title logo animation play, then switch to web cam. Two layer sets set up, switching with automation layer.

When automation layer does not fires, this problem never happens.

I reproduced other project file.

Weird. Thank you for this update. Can you please publish the code of the automated sequence? (simply the source code?) I want to rebuld the automation and the setting, to test it too.

(Please give a note, in which section the automation has to be placed. On Live, while live… or “Automatic”-Mode)

setVariable($openingSet, "0676082C-DD67-487C-A51A-4BFB282C5E4D")
setVariable($mainSet, "57AB9987-06DA-4DE5-9C69-584544182FAC")

layerSetRecall($openingSet)

sleep(9)

layerSetRecall($mainSet)

(Please give a note, in which section the automation has to be placed. On Live, while live… or “Automatic”-Mode)

I use Automation layer in two way. First, when start show. Second, I need to call Automation layer on demand. It just push “Live” button on Automation layer.

My apologies.

I move the .tvshow file made on M1 Mac mini to MacBook Pro 2017 Intel. After few hours testing, I confirmed it works without the problem on MBP2017. I said this problem occurs on MBP2017 too, it was my misunderstood.

This problem seems to occurs only on M1 Mac mini. The current version of mimoLive does not support M1, @JoPhi said, so it might be not helped this issue by Boinx staff.

UPDATE: I tried tests many times, the new fact is found out. It’s not necessary to Automation layer is bad. It seems to be heavy load on mimoLive, when it circumstance the phenomenon reproduced. In particular, when many layers are toggled in short time, or multiple Placer with footages plays at the same time it occurs.

Unfortunately, the spec of my MBP2017 is not enough for layer stacks that I consisted and expected. Except this issue, the performance of M1 Mac mini is so excellent for mimoLive. I hope to mimoLive does get to work on M1 normally ASAP. (Also Rosetta2 is OK)

Don’t worry, I’m sure that your post about M1 does truly help in case of M1 itself. Now it’s clear that the phenomenon is connected to M1. :hugs: (And who knows, maybe it’s simply because of the charset handling through M1/BigSur/used mimoLive under the hood magic/Rosetta2-translation… or other/else reasons. A good hint to check something in a none-public alpha test.).

I’d take care about this and would include this information to do sample tests and/or check-ups.

For one of my projects it was very important to check the functions around several charsets, and your post reminded me to think also about Kanji, Katakana and Hiragana, so - for me - a reminder came mysteriously from the cloud. :hugs:

UPDATE:
I found out some new facts yet again.

NDI Video source is also same behavior. I used ProPresenter 7.5 with NDI Syphon. I added video source NDI video and set to Placer layer variant. Once it behavior was OK, but after some layer sets changed, NDI video source has never came back. Just black screen appeared.

It means that the cause is not for that movie files and it’s for mimoLive’s video switching function doesn’t work well at M1, doesn’t it?

And I would like to say another point, when many times push the layer live button or layer set recall button, sometime media file sources and NDI video source doesn’t show up, but the webcam Logicool C920n’s source always fine to show up. It means UVC is OK, another one is not OK? Hmm, I have no idea.

By the way, I paid attention to the render performance monitor. It shows always that “Free GPU memory: 15MB of 10.67GB”. Is this correct? I wonder it’s not at all.

Besides, the video source from ProPresenter with looped footage via NDI syphon plays little bit jerky. I think it might be cause for that NDI and NDI Syphon doesn’t optimized at M1.