Missing Media Error: Does This Fix Work for YOU?

I have posted this in another thread that discusses the issue, but the results of my efforts have been so positive that I thought I should post a new thread with what I believe is the solution for F4 users who have this problem. I did a search online but have not seen this solution elsewhere, if it is already posted . . . my bad.

I’ve been having the same issue since using F4 on a friend’s Mac. Each and every time I reopen Fotomagico 4 I get the “missing files” error and have to rebuild 66 music and image files. It’s maddening!

But there IS a fix and it’s really a very simple fix. Go to your created and saved Fotomagico File and right-click on it and choose, “Show Package Contents”. Inside you will find these folders: Audio, Images, Cache, QuickLook and Titles. Open your Images folder and drop all of the photos you are working from or missing into that folder. In my case I had over 300 images and didn’t want to take the time to catalogue the missing ones and thus only replace those, so I just put all possible in that folder.

When I reopened the slideshow, all of the photos were in place, but the music was missing again. So I closed the app and looked in the Audio folder and sure enough the music files were missing too. I dropped in the music files in and the next time I opened the slideshow in Fotomagico 4 all of the photos were in place and all of the music was too.

I’m in the process of exporting to Quicktime to test my solution. If it turns out that the slides are still missing I’ll post a note, but I’ve opened the slideshow several times post-fix on two different Macs and they all populate each time, so I believe this is a reliable fix. Is this just a fix for my Mac on my system? I doubt it, but I’d be interested to see if this fixes things across the board for all users with this issue.


I’ve tried this fix but unfortunately it does not work for me (Mac). I put all my Images into the “Images” folder - restarted FM4 and…everything’s the same as before. “Missing Media” Damn.
What about the other users?

I have the same problem, and will probably go back to version 3. $100.00 for nothing!

Hi everyone. We released a public beta version of FotoMagico 4.3! This should fix the problems with missing media files.

If you are interested in testing this version and giving us feedback about it, please read this post carefully!

IMPORTANT NOTE: The FotoMagico project files once opened with 4.3 aren’t backward compatible! They can’t be opened with earlier versions anymore! Please make duplicates of your projects before opening them with this beta version!

  • Download FotoMagico 4.3b2 from the link below. Your web browser will download and extract it to your download folder.
  • You can move the downloaded application anywhere in your system, there is no need to delete the earlier version of FotoMagico, they can co-exist in your file system. However you have to be careful not to double click any FotoMagico slideshow project! MacOS-X is choosing an application version by random if no FotoMagico is currently running. So please when having FotoMagico beta installed only open up project files with the dedicated “File > Open…” menu item of FotoMagico to make sure that you open the right file with the right version of FotoMagico. Double check the running version in the “FotoMagico > About FotoMagico” window to make sure you are in the right version of the app.
  • Please make duplicates of your FotoMagico projects in Finder before opening them in this beta version! Once they get saved with this beta version they won’t open in earlier versions anymore!
  • If you have finished your testing you can move the beta version to the trash. MacOS-X won’t start applications from here.


Any feedback is highly appreciated! Thank you very much for your patience and support!

So, I installed the beta version with a demo license.
Made a Backup of my Project and started it in this beta…same problem. Missing Media!

I found 3 things with the beta version:

  1. if I had the missing media problem before, it exists with beta also
  2. does not handle 24-bit audio files (FM used to handle these just fine)
  3. if I start a new project, and use 16-audio, then everything works fine. But I did need to start a new project.

@LionelTwain @MathewUSF: Thanks for giving the beta a try! I am sorry, I didn’t mention the fact that FotoMagico 4.3b2 won’t resolve the missing medias if they are really missing already in the project. You will have to resolve those missing files with this beta and save the project again. After that there shouldn’t be any missing media files anymore.

@MathewUSF: What does “does not handle” mean for you? You can’t add the audio to a FotoMagico Project, or doesn’t play back? What are your steps and what is not working?

I’m embarrassed to say I don’t remember (it was a few days ago, and they’ve been busy days). If I remember correctly it would lose the file (missing media issue) even with a new project. No 100% sure, but pretty sure that was the issue. Unfortunately I’m about to leave on a month long trip so I don’t have the time to test this out before I go. If I end up with more time than expected, I’ll test out again tomorrow.

@MathewUSF: Thanks for your help anyways!

Okay, got the chance to test this again. This is using the FM 4.3b2 beta supplied on May 30.

The more I play with it, the clearer it becomes that it also is unreliable. Much better than the previous version, but weird things still happen. What I’m not able to accomplish in my small playing around are reliable bugs. So, yes, adding a 24 bit audio at times seems to result in a problem: this morning it was closing, then reopening to missing media. So, that may not be a 24 bit problem per se. With the previous version I couldn’t even play 24 bit audio (it would freeze up).

However, I did some other playing around. For example, from within FM at times if I change the audio (e.g. swapping one audio file for another, or changing the length of the audio) then the audio won’t play after that change within a session. If I quit and restart then all is fine. Other times this doesn’t happen (that’s the “unreliable” part).

The primary worrying thing is less the 24 bit audio, but in previous versions of FM4, if I saved then you could see the program saving the files within it during the process. But now if I press save nothing seems to happen, but once I want to close or quit, then I’ll get the dialog box shown below. And, I think, the problem is I don’t always get this dialog box when leaving the program (again, the “unreliable” part). At any rate this undermines confidence that the program is behaving correctly. As a user I would much rather see it actually saving all the media then getting this dialog box at the end. I know changes have been made to “speed up” this saving of media, and that’s much appreciated, but perhaps in the speeding up process some reliability has been undermined. In the end, reliability will always be more important than speed (though we can always wish for both).

At some point I turned off “auto-save” in the preferences. After that point I didn’t experience any actual problems, though of course I still got the “unsaved media files” when closing (instead of being embedded when using “save” before closing). So, again as a guess, maybe something about auto-save was generating some unreliable behavior. At any rate, I’m leaving it off for now.

I also tried the beta and even with a complete new project it happened again to have missing files. Even all files were missing. So honestly for me this version is worse.

The option to locate missing files is a joke, as I get a list of 574 files with a Find button beside every file. Why can´t you do this automatically? I mean it points me to the right folder and the name is correct. So why there is no option to automatically search the files in a folder? It´s two lines of code.

I´m really dissapointed and will go back to 3.8.

I hope you can fix this soon.


@MathewUSF: Thanks for your feedback! About the saving process: FotoMagico 4.3b2 checks wether there are media files new to the project (then it would do save all the media agian) or you have made only small changes (e.g. changing the duration of a slide) then it only have to save the project structure which can be done really quickly. I see your point that this behavior isn’t consistent.

@netrene: Thank you for your feedback! About finding files: The problem is, that FotoMagico can’t see the files and the folder structure because of the Sandbox-Demon which protects your private data from being spied. The file chooser dialog you are prompted to search for the missing file is actually running on system level and we don’t have any hands on whats it is shown there. Also we can’t search your hard drive because we don’t have any access to your file system. Btw: This new protection technology by Apple is the root to the problem: We are granted access to those files the user is selecting in the file chooser. And we can loose this access afterwards, this makes some trouble.

However, I would like to hear about your workflow in order to reproduce your problem with the missing files. Please remember: we are depending on your cooperation to fix the issues. If we can’t reproduce them we can’t guess a fix for it. Thank you!

@Achim I need to create some fairly basic slideshows in the next month. What are my options for a reliable version? Whatever version was current in November 2012 seemed to work just fine. Is it possible for me to get that version? (I will be 6,000 miles from home over the next month with some spotty internet connections.) Or is my only alternative to use v3?

Now that I know there’s a problem (and I can believe the whole Sandbox thing is at the center of it all), I’d be glad to help with testing things out when I’m back home w/o a time pressure to get certain things done. But in the next 30 days I need a product that is rock solid.

@MathewUSF: You may download the FotoMagico 3.8.8 from our website: http://www.boinx.com/download/#fotomagico (in the "Previous Versions section) If you have a valid FotoMagico 4 license this will also work with this version.

Great! Many thanks.

I will do an online session tomorrow evening with Peter and help reproducing the problem. If all trouble is coming from that Sandbox thing just remove that crap. At least the customers that did not buy your software via the Apple store (like me) would appreciate that. The disadvantage is that you´d have to maintain two versions.

@netrene: In general the Sandbox technology is a highly appreciated step forward by Apple to protect users private data and keeping the system clean from viruses and malware. The same technology is running on iOS and thats why there aren’t any viruses yet (in opposite to Android). We at Boinx want to support Apples fight against viruses and therefore we have to implement the necessary API.

The following week there will be Apple’s World Wide Developer Conference and we are sending out our engineers to discuss the use of this technology directly with the Apple engineers in order to tell them how we are using their code and learn about our mistakes.

Sorry but I have to disagree. A software that is virussafe but not usable doesn’t help anybody. I understand that Apple restricts your way of programming too much. I mean if you can’t search for files on the filesystem anymore than this Apple protection paranoia reached a stage where it seriously effects your software quality. I don’t want Apple predesigned software that looks all the same and is not usable at all.

The fact that your developers try to learn at WWDC how to use this, shows me, it was to early to implement this stuff.

Keep thinking different is gone? Every Software company should use the Apple ideas? This is going more and more in the wrong direction for me.