Mimolive 612 + Krisp.ai Audio dont work

Version 6.1 AND 6.1.2 (29769) dont see krisp source

Krisp works fine with Zoom, Skype, QT
Tried this as well, but without success: **Outdated Virtual Camera Plug-In** - #12 by Nick_B

ps. tested on Macbook pro

tested on second Macbook pro

I use Krisp and it has been working for me. Will check settings tomorrow because my default is actually to run krisp into mimolive via soundsource to add some effects and then loopback as a virtual cable.

Can you please explain this interesting scheme of connecting and using Krisp?

Tried add Krisp microphone in agreggated audio device in MIDI settings, no succes

Hopefully this can help you see what I do.

1 - you are right Krisp Microphone isn’t showing up as a source in Mimolive. So I am replicating your problem.

However my setup is working so its a potential workaround for you.

I have Krisp Microphone redirect from Soundsource to a loopback device. That enables me to add effects to the mic in soundsource (improves voice sound).

In Mimolive I have the Loopback Device as a source.

You can see from the sound levels in the screenshot (Left to Right)
A) Sound is coming through in Mimo
B) Sound is coming through in Loopback Device
C) Sound is redirecting from Krisp to my “Krisp Soundsource” Device

Hope that makes sense

FYI I have two Krisp sources in Mimo - one with a delay as I have a video source that is a little slow. Both the Krisp sources in Mimo come from the same mic - but via two different Loopback Devices. One has the Krisp mic as a pass through and the second one that I delay has the other Loopback source as its source. You can see the soundlevels in the Mimo sources are not quite in synch. It works!

1 Like

Why do you need SoundScource in this scheme?
Mimolive sees the source from the Loopback

I found using the soundsource FX easy way to make the krisp output sound better. I add their “boost” and play with Equaliser. Sometimes reverb. Can really make a difference. If you know better way let me know.

1 Like

@Nick_B Can you share your settings for soundsource’s FX and equaliser for Krisp output? (I have no skills as a sound engineer at all).

@Oliver_Boinx Is it possible to see Krisp in Mimolive directly? Is this a bug or is this a technical limitation of Mimolive and is it necessary to use a proxy solution via a paid loopback?

I’m not sure what the deal with Krisp is. As far as I know we do not filter the list of available audio sources, so if Krisp is providing a proper audio source to the system, it should show up in mimoLive.

But there was a problem with Krisp which we solved in mimoLive 5.10 (Reference here) which might mean we did exclude it somehow, so I will have engineering look into that.

i tried this, without succes:

Update - if I move the Krisp driver out of /HAL/ the Krisp mic still works and so does ML 4.9.1. However if I restart the machine then Krisp stops working. So one workaround for the time being seems to be open with Krisp driver in HAL then move it out and then open ML 4.9.1.

Skype, Zoom, QT, Teams app, Teams in Chrome - see Krisp, Mimolive dont see krisp

Hi @did That’s because that workaround was to make mimoLive’s Virtual Camera work again, not Krisp.

When Krisp was installed, the Virtual Camera didn’t work.

This is a different issue but might have lead to us blocking Krisp when mimoLive is running. I don’t think this is the case but I will have to check with engineering.

I just tested Krisp and find it doing very strange things. The “Krisp microphone” is indeed mute in mimoLive. The Krisp website says that it needs to be enabled for specific apps, so it might be possible that mimoLive is blocked on Krisps end. We’ll look into it next week.

1 Like

Hi, Any news about krisp integrations?