Alpha Channel in Mimolive layout not what it is in preview

For any animation of images or even lower thirds I usually use After Effects to edit the animation, export my Composition as mov, Apple ProRes 4444 +alpha channel. Until now there never accured any problem. The play out in Mimolive was as seen before in After Effects.

For a recent project I’ve worked out some animation in After Effects and now the play out in Mimolive isn’t anymore what it is in After Effects. Where a color should fade into nothing it fades now into white. Even when I export the alpha channel additionally an use it as a mask in the placer-layer the output is not what it is in After Effects.

I’ve updated my whole system to the latest Big Sur Version, Mimolive is updated as well.

Does anybody know where to find a mistake or what reasons could lead to such an output?

Hi @christian.boenisch Thank you for joining the forum and for reaching out.

Can you please send me the video file and let me know what version of mimoLive you use?

You can find my mov file here:

211113 animation mit alpha-kanal

(and a screen-capture from what mimolive is replaying)

The Mimolive-Version is:
Version 5.11 (29401)

macOS: Big Sur 11.6.1

Thanks for sending the file. I can reproduce this issue, but it is a bit baffling as we are using this method for years. But with your file we can investigate further.

Does this phenomenon disappear, when you terminate the PGM out with a black background (Background-Layer, solid color: black)? Maybe this makes a difference. (PGM on transparent background is a feature in mimoLive (use as a graphics engine) but sometimes, a true black is necessary.)

@christian.boenisch We have investigated the issue and found the cause. mimoLive requires the ProRes 4444 file to be in “Premultiplied Alpha” mode. The file you are using is “Straight Alpha”. (More on the background and how to set this in After Effects) This is a fairly recent addition to ProRes and After Effects which we have previously missed. Thanks for reporting this.

We’re working on supporting both Alpha modes in a future version of mimoLive. Meanwhile, export your file in PreMultiplied mode to make it work.

3 Likes

Well, the article you posted on how to set this in After Effects deals with footage interpretation, wich is something i can’t bring in connection concerning this issue. There is no footage in my animation. The animation will be footage at some point
Anyway, in the option menu to set up the ProRes 4444 + alpha channel for rendering directly in AE there is a drop down menu where you can choose between Premultiplied Alpha mode an Straight Alpha mode. But: The result is always the same.

Sorry to say, but there must be something else.

In fact, when the PGM-Output is black it looks quite right. But in this case we used MimoLIve as the PGM-Output not as a Source for graphics.
Anyway, now there is an additional issue: the animation playback is not fluently anymore.

For this production we had to find work arounds and used static graphics instead. But for future use we need to find a solution for animations.

Can you please send me the AE file?

Could you please add information about the hardware specs of the used mac and GPU? Maybe I missed it.

Here you can find the After Effects File and some other stuff :
[ Here should be a link to the files but the forum does not let me post my post when there is a link in it ]
screencapturing of the playback in MimoLive wich does show what it should not show and in addition doesn’t play fluently at all!
And you can look at the mov file that is implemented in MimoLive as shown in the screencaptures.

How can I post a Link?

Maybe the best would be to send the link to Oliver as a private message in the forum.

Test:
https://youtube.jophi.guru/

Does it work for me?
EDIT: yes. I simply let it as a text there.

I have run into this as well. It affects the preview only. However, if the video switcher is NOT set to PreMultiplied, this can actually affect the actual output.

I’m not sure why your experience of output from AE in ProRes 4444 would change in ML though, but a workaround could be to simply put the Kineme AlphaBlendMode.plugin file into ~/Library/Graphics/Quartz Composer Patches/ folder (make these nested folders if they don’t already exist).

I’m getting back into mimoLive today and installing QC on Big Sur on an M1 mini (fingers crossed). When I was putting the mimoLive required QC plugins into the ~/Library/Graphics folder, I checked the other Patches and Plug-ins I used to use and notice Kineme’s AlphaBlendMode.plugin (actually a patch) and that was really important for getting proper alpha on my compositions 7 years ago.

here’s a link to the Alpha Blend Mode plugin (patch).. Possibly would need to go inside the ML app folder but not in my previous experience admittedly seven years ago!

I don’t know how to do a private message and as soon as I post a text wich is a link this forum refuses to post the message. Why is this so? :thinking:

EDIT: I could send a private message as response to a privat message. Still i don’t know why i can’t send a link in a post.

Just click or tab on Oliver’s face and select this Button.

Try to remove “https://” if you cannot post the link. I’m sure that Oliver is able to identify the string as such.

Links in posts work fine for me.

@usefulDesign @christian.boenisch @JoPhi

The forum allows posting of Links/URLs only after a user has been a member for a while to battle spam.

1 Like

makes complete sense!