You've invented time travel! Not sure you meant to.


It’s all gone a bit wrong. We were broadcasting out today from the past.

As you can see from one of our shows today (skip about 2 minutes) - the date is now wrong. Instead of being 2nd Oct - it’s 01 Sep. This seems to have occurred since we updates to v3 (latest) and using the Date/Time Layer shortcut %d %b

I thought it may be a machine problem but it’s the same on this test laptop.

I’ve fixed it for now by just manually entering the text to reflect the date. Anyway, just a heads up.


@MrAndrewMcLean I’m sorry you experience this problem, but thank you for reporting it. We’ll investigate immediately.

Hi Andrew.

Do you have Quartz Compozer installed ?

I’ve looked into the Date and Time composition, and in the LUA patch that have to create the date string, Boinx team has done a math expression to make LUA and QC havin the same time.

When I displayed the composition, its display : Monday, 01 October 2017.

So, I found 2 solutions (Only tested in QC, not Mimo) :

Found this line in the lua :
local displayTime = inSystemTime + 31*365*24*60*60 - 23*24*60*60

-Changing the maths, in my case I changed 23*24*60*60 to 22*24*60*60, that bring me back to 1 day before, so the first October, but in your case you have to add 7 days (and not substract 23)

-I replace the inSystemTime in the local displayTime by a os.time(), and commenting, by adding – before, the mathematic expression.

If you can’t/don’t know how edit compositions, I’ll upload you the “fixed” version, to test on your device :slight_smile:

@MrAndrewMcLean Sorry for the trouble! @ToD Thank you for debugging!

I introduced this bug when adding the time offset options in the last update. Unfortunately I forgot some places that would also love to have this shifted time. The result was, that the month name was calculated on a different time base than the day of month. So you can get a 31st September even that it doesn’t exit! :smiley:

Here is the fixed layer version that will come with the next release of mimoLive. For now just download the file and double click it. It will install itself in your current mimoLive installation.

@“Achim (Boinx)” No problem ! It’s a pleasure !

I’ve took a look on your fixed version and have a little question : Why don’t you use os.time() ? Its can generate an error depending on the machine ?

Thank you both for your help!

ToD, that’s awesome. I didn’t have time to look “under the hood” but I’m hoping to brush up my scripting skills with mimo very soon.

Achim, the patch worked beautifully. Thanking you.