"Your system has run out of application memory" while running mimolive


I seem to be running into a recent issue while using the application. While streaming, mimolive seems to utilize a hefty portion of my memory and will abruptly crash my computer. This is the first time it has done so, as previous streams have managed to work just fine with the same amount of layers present and live.

I’ve tried bringing down the quality as well as deleting some layers/sources, but my computer will still run out of application memory even though I’m running 16GB of RAM. I’ve also tried closing out other applications that were running in the background as well as resetting the PRAM but I’m still running into the same issue.

I have a feeling this could be happening on my end, but I wanted to hear what you all think could be the cause of it.

I am running mimolive version 2.9.1 (also tried running version 2.9.2b2 but I still ran into the same issue).

Is this also happening while you are not streaming just having the document opened? (You can monitor the memory consumption of every app with “Activity Monitor.app” by Apple installed on every Mac)

If so, it might be something with your document. Please can you recreate your document step by step an check if one certain addition will cause this issue (e.g. if you are using a certain layer).

If it is only while streaming I would like to take a closer look at your streaming settings. Hopefully we will be able to reproduce the bug and fix it.

Thanks for your time testing all this in advanced.


After testing around with it, it seemed to be just a document issue. However, if I ever run into this problem again I’ll be sure to let you know. Thank you so much for the support!

I have noticed this occasionally with a chromakeyed window capture source. It usually happens when the document loses the connection to the Window capture. I have gotten into a habit of checking the window capture source before starting a stream to ensure that I don’t run into this issue when I go live. If the window capture source isn’t working I can just reselect the window from the source’s drop down. As long as I haven’t made the layer for it live yet it does fine.