Why don't All Keystrokes Appear?

I have just installed Mouseposse and I am experiencing the same issue on MacOSX latest OS X release mentioned by Don Smith below.

How do I resolve this issue?

Only modifier keys showing, even though options is selected.
donsmith said:
Mousepose is great but cannot get the keystrokes display to act correctly.
It only displays modifier keys and nothing else. I have it activated and the filter is set to All keystrokes and Do not show: Mousepose hotkeys. Of course I tried all other filter combinations. Intel Mac Pro running latest Snow Leopard.

Which MACOS-X version and which Mouseposé version you are using? In the “Keystroke Filter Options” of Mouseposé did you select “Show: All keystrokes”?

Hi :slight_smile:
I use Mouseposé for Logic Pro X training (non-App Store version). After I install Mac OS X Maverick 10.9 Mouseposé stop to show any letters in keystrokes, just show only modification keys. I test it on more computers with clean installation with “Show: All keystrokes” setting. My question: when you plan to release a Maverick-compatible version? Thanks in advanced!

@Ultrabeat: Thanks for reporting, we will have a look into it.

I investiged this issue yesterday. Apple introduced a new security feature with Mavericks. We have to change some code in Mouseposé to make keystrokes works again. Next week we will decide how to go on.

Thanks for info, Stefan :slight_smile:

It does work properly in Mavericks if you allow Mousepose in System Preferences/Security/Accessibility/Privacy and then restart the computer.

We submitted an update at Apple for review and expect the approval within the next days.

Mouseposé 3.2.4 finally arrived in the Mac App Store. It will ask you to grant permission in the System Preferences the first time you activate keystrokes.
Maybe you need to restart Mouseposé afterwards, but then it will show all the keystrokes as you are used to.
We apologize for the delay and hope you satisfy the update.

Well, that’s good but I’ve licensed Mouseposé via Boinx website and the 3.2.4 update is still not working. When downloaded, I get a message error.
Please, how can I manage it?

@Nefelibata: Are you updating the software directly within the app itself? Which version are you running? Try to download the Mouseposé from here manually and replace the app in your applications folder: https://cdn.boinx.com/software/mousepose/Boinx_Mousepose_3.2.4-10838.app.zip

Yes, I was updating from the 3.2.3 (Rev. 10788-F13879-R) version.
Now I’ve replaced with the link you provided and it is working fine.

Thanks for your fast help!

I’ve got the same problem; no letters are displayed. If I download the file suggested by Achim, everything works fine, but I have to enter a license key. But since I bought Mouseposé over the MacAppStore, I do not have that specific license key.

What do I do? I don’t want this little Window “plase buy me!” in the corner of my screen, neither I want to click through the whole activation window every time I start Mouseposé.

I’m running the latest version of Mavericks; Mouseposé is Version Rev. 10838-F16047-R.

uuh, I solved the problem. Thanks to this thread: http://forum.boinx.com/discussion/3777/os-x-mavericks-keeps-asking-for-universal-access-support-even-though-i-granted-it#latest
You just have to delete the com.boinx.Mousepose-files in your library.