Ultra Studio 4k Mini


I am having trouble getting my Ultra Studio 4k Mini to work for live streaming with my M2 MacBook Pro.
Capturing a 2160p59,94 signal works just fine but cannot get the output via HDMI or SDI to work with 2160p signals. It is either distorted (HDMI) or stays black (SDI). 1080p works fine.
Since rendering times are well below 10ms I don’t see an issue with the Macs performance, although it shows dropped frames and states a performance issue.
I am not using the Macbook for the stream encoding. For that task I use an Webpresenter 4k.
The preview windows also look fine.
I would appreciate if anyone could help me with this.

Best regards,

I did some more testing:
a) I installed the latest BMD Driver (12.7). Unfortunately that did not solve my problem.
b) 2160p29,97 output works, but a popup tells me that there are performance issues and frames are dropping (about 20 per update increment)
The sounds seems to be fine.
c) I also tried to play out a file from hard disk to make sure, that it is not the bandwidth of my thunderbolt connection not being able to capture and playout at the same time.

I would appreciate if anyone could point me towards a solution or if anybody could tell me his/her setup if he or she has a 4k60 output working with the Ultra Studio 4k Mini.

And some more …
I also tried this on a Mac Studio M1 Max.
Unfortunately that also does not work and since I already encoded a 4k stream within OBS with that machine I don‘t think that I am limited by the cpu or gpu when experiencing my Decklink output problem.

HI @Kalle_Grabowski I’m sorry about the troubles.

Can you please try mimoLive 6.5b2 and get back to me with results?

Thanks for the quick reply.
Unfortunately I won‘t have access to my hardware until Saturday, but I will get back to you with a result as soon as possible.

I tested 6.5beta2 today. It does not state the performance problems anymore, but it is still dropping a lot of frames and the preview picture on the Ultra Studio is still distorted.
in 2160p29.97 the preview picture looks okay, but there is visible frame loss.

I have tried to capture and playback 2160p59.94 files with the device using the same cables and computer etc. via the BMD Media Express App.
That worked like a charm, so there can’t be a general cabling or performance problem.

Hi @Kalle_Grabowski Thanks for trying the capture and for reporting the results. I’m glad to hear that that is working.

Regarding the playout, we’re currently getting a Blackmagic Ultrastudio 4K Mini in order to being able to reproduce this. This will take a few days. Thanks for your patience.

1 Like

Hi @Kalle_Grabowski we’ve been able to reproduce the problem. While we’re working on it, you should bot have any trouble encoding the 4K signal on the Mac directly to stream it out via RTMP.

1 Like

Thanks for taking the effort! I am glad, that it is not a bad unit or user error on my side.
Since my broadband connection at home is too slow, it will be a couple of days until I can test the direct output. OBS, which I used before, seemed to struggle to encode 4k60 on my M2 MacBook Pro, but the Mac Studio worked. I since bought a Webpresenter 4k to be independent of any Mac-Encoding problems, that is why I need the output.

Hi @Kalle_Grabowski We’re looking at this with the help of Blackmagic engineering. Meanwhile, have you been able to try using mimoLive to encode your stream?

My internet connection at home is too slow, for a test at home and I have not been to the rink yet.
Instead of streaming to Youtube I tried to write to disk with a similar bitrate. That caused frame drops also and the pop-up states “performance issues”, so I would assume the same will happen while streaming.
These observation refer to my MacBook Pro with an M2 Pro. The Mac Studio with the M1 Max should do fine.

@Kalle_Grabowski Thank you for your patience. We’ve received some helpful pointers from Blackmagic who were able to confirm the issue and hope to be able to provide a fix soon.

Hi @Kalle_Grabowski We’ve fixed the playout issue in mimoLive 6.5b3. Can you please download and try this to confirm that it works now? mimoLive 6.5b3 | mimoLive®

1 Like

That is great news! I am still traveling and don‘t have access to my stuff, but I will give it a try on Saturday.

Just a quick update:
The 4k59,94p output seems to work now, which is great news! Thanks for dealing with this problem so quickly.

Unfortunately during my short test I now encountered other problems, that I have not tracked down yet.
One problem was, that I could not capture my cameras output via the 4k Studio as an input for some unknown reason. A fresh start of the unit solved that problem but then I ran into memory issues, with mimolive consuming 65 GB after a couple of minutes playing around.
I have not been able to dive into diagnosing this problem, so I have to make sure that it is repeatable before I can come back with any specific details.

1 Like