Text colour goes transparent

I have been having this problem for a while now, the text when in two colours - say descriptive text in green and a numerical date in grey, with a separation space between them. At a later date I want to edit one of the colours, the whole text goes transparent, the text is still there you just can’t see it. I recolour it in one colour, its OK, if I introduce a second colour it goes transparent again. Before using my new Mac 64bit I was able to delete the Boinx preferences from the Library, which tended to cure it. But there is no Boinx/Fotomagico file in the Catalina library/preferences folder. Help please.

I tried to duplicate what you described but it seems to be working fine for me (Mac OS 10.15.3 using FM 5.6.13). And not sure where there would be a setting to change that behavior. Sorry…

I think it may have something to do with the Emoji/Symbols in the Fotomagico edit menu. I have used the small bullit midway between the Text and the date as a convenient way to insert a mid-leading dot. I used PopChar previously, but it stopped working with OS Catalina and I had to find workaround.

Okay, that changes things. So I just tried inserting a bunch of random characters from the Emoji & Symbols drop-down menu. I typed in emojis, symbols, bullets, math characters, made them different colors (although you can’t really change the color of an emoji), then saved the file and then reopened it. Went back to the text block and was able to change/edit each of the characters as expected. I did use PopChar a long time ago as well, but just gave up on it. Something else must be going on. Maybe the guys at Boinx can come up with answer. At this time of COVID-19, not sure how they are managing things on their end, though.

I have run out of options for this problem, using my old Mac 32bit computer I was able to delete the Boinx preferences from the Library, which as I said earlier tended to cure it. But as there is no Boinx/Fotomagico file in the Catalina library/preferences folder, where is the Boinx preferences now located?

There IS a .plist file located at ~/Library/Preferences/com.boinx.Fotomagico5.plist – BUT, whether that’s the prefs file that needs replacement, I’m not sure. I’d hate to tell you to delete that and then hope that it will be automatically recreated when you re-start FM.

Sorry for the trouble. I can’t explain whats happening here. If you want to you can delete the FotoMagico preference file at this location: Make sure the app is closed! (Actually sometimes a reboot of the machine is necessary between the steps because macOS holds a cache for the preferences somewhere else and updates the actual preferences file only on idle times, you may monitor the modification time stamp of the file to make sure!)


(the long path is because FotoMagico is sandboxed and therefor a requirement by Apple)

Thanks for that, I probably would never have found it in its new location on Catalina