Teams Mimolive camera virtual no longer detected?

The MimoLive virtual camera is no longer detected in Teams. It was working 3 days ago ??? Same for NDI ???
The audio is ok…
Did you have the same problem do you have a solution?

Yes, MS Teams found out they had the same “security” issue as Zoom back in April.

Microsoft official info: https://docs.microsoft.com/microsoftteams/troubleshoot/teams-on-mac/virtual-camera-doesnt-work-macos

There are two workarounds:

  1. Use teams in the Chrome browser
  2. https://answers.microsoft.com/en-us/msteams/forum/all/microsoft-teams-mac-os-client-is-not-recognizing/d9e863be-d9a4-4d03-a4b8-1b5c7df58828?auth=1
1 Like

This happened to us out of the blue last night. It was working earlier in the day. The second work-around that Oliver points out worked for us perfectly. Strange that we did not notice an update to Teams.

Thanks for using mimoLive and for joining the forum!

I’m sorry to hear about the problems. Microsoft forces updates in the background. You can turn this off somewhere in the Teams settings. I hope they will fix it soon as Zoom did.

Is this still the reason why the Virtual Cam does not work in Teams on Mac?

Unfortunately, there is no new info from Microsoft on when they are going to re-enable virtual cameras in Teams.

OK. Thanks for letting me know. Any smart suggestions maybe on how to work around this? I haven’t (yet).

Microsoft recommends using the web browser (Edge or Chrome) to work around this.

Oh yes, sorry, missed that one. You’re right. Thanks, will try that (when not being able to use Mimocall :wink:)

Is this still a known issue? By which I mean using a virtual camera in Teams. I have a talk coming up on the 11th March and just found out they want to use Teams (booooo hisss). Have previously used Chrome successfully though.

Yes, this is still a known issue and there is no new info from Microsoft.

The recommended workaround is to use the Chrome browser to access the Teams meeting.

Thank you. Chrome it is then!

This fixed it for me:

Option 2: Remove Teams Code Signature

Removing Team’s code signature is another way to re-enable virtual cameras. To do this:

  1. Ensure that you have the latest version of Microsoft Teams, by picking Check for Update from the menu in the top right corner of the Teams window.

  2. Once you’ve assured that you are up to date, completely quit Teams.

  3. Open the Terminal app, found in ApplicationsUtilities.

  4. Copy and paste this command into Terminal and press return:

sudo codesign --remove-signature "/Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper (Renderer).app"
  1. It will prompt for your Mac’s admin password. Note that you will not see anything happens when you type it. Press return.

  2. Re-open Teams.

1 Like