Struggling to get SDI Playout to work with Decklink Duo 2

As per the topic, I have a decklink duo2 connected to my Mac via thunderbolt (in a sonnet chassis). I am able to output the fill signal but can’t get the key signal to output.

I was able to get things working with an Ultrastudio HD Mini. This has 2 outputs only, so connecting an SDI cable to each, then connecting those 2 two inputs on my Black Magic TV Studio HD, I was able to set my upstream key to use one SDI in as Fill and the other as Key. MimoLive saw the USHDM device and all I had to do was select the device, set keying to external and it just worked.

I’m unable to do this with the Decklink Duo 2. I am able to output the fill signal but can’t figure out how to get the key outputted too.

Here’s is what I have set up:

In BM Desktop Video Setup

  • Decklink Duo 2 (1)
    – Video Output 1080p59.94
    – Connector Mapping: SDI 1 & SDI 2

In mimoLive

  • SDI Config
    – Device: Decklink Duo 2 (1)
    – Video Format: 1080p59.94
    – Audio: 48.000 Hz, 32-bit, Stereo
    – Keying Mode: External

In TV Studio HD

  • Physical Connections
    – Decklink Duo Connector 1 -> SDI input 6
    – Decklink Duo Connector 2 -> SDI input 7
  • Upstream Key 1
    – Fill Source: SDI Input 6
    – Key Source: SDI Input 7

I can see the Fill quite clearly (using multiview) in my Inputs (strangely enough, but no matter what I do I can’t seem to get transparency information to come through.

Things I’ve tried

  • I’ve tried setting connector mapping to separate pins. I’ve tried setting Key and Fill sources to a single channel. I’ve tried all sorts of variants of pins, output settings etc and none seem to work.

As I’ve said, I can get this working using an Ultrastudio HD Mini, but that has just 2 SDI outputs and it seemed simple enough to get going but the Decklink Duo 2 is being difficult.

(If you ask me why I’m not just using the Ultrastudio devices, it’s because the Key/Fill input fails after a number of minutes (image freezes on the TV Studio HD). The only way I can recover is to close mimoLive and open it again, then restart SDI output. So I’m trying to get the Decklink card to work to see if I get the same fault with that.)