Strobing/choppy audio

BMD Ultrastudio 4K.
MacOS 10.13.5
ML 4.3.1

Audio begins to ‘crack up’ after several minutes until it’s totally unusable. The ‘crack up’ is a total loss of audio for a few milliseconds at a time that becomes more and more frequent. It sounds like clicks or static or strobing. Here’s a shot of what the audio waveform looks like: Choppy Audio Waveform

Issue is resolved by restarting mimoLive. Then it’s stable for a few minutes before the audio begins to crack again. Never had the issue before Sept. 16 and, as far as I can tell, nothing had changed. I confirmed that the audio is good/clean through the whole signal path up until mimoLive (monitored the audio directly off of the Ultrastudio and it was totally fine).

Updated mimoLive to latest beta version.
Updated to 10.13.6.
Updated all BMD software.

Still no joy. Precisely the same problem. I’m desperate to get this issue resolved before Sunday.

The audio I captured is just a straight sine wave. All of those gaps are VERY brief total audio loss.

@camsna Can you please check and let me know if it works with mimoLive 4.4?

It does not work with 4.4. Same problem.

It was working fine and, as far as I can tell, nothing changed. I didn’t update ANY software, hardware, or firmware in-between the time when it was working and the time I started having this problem. So – I’m stumped. In an effort to troubleshoot, I’ve done all of the following, and none of it has solved the problem. (Also, I can confirm that the problem is ‘inside’ mimo. Audio coming off of the camera, mixing console, switch, capture card – all fine. And restarting mimo resolves the problem for a few minutes.)

Updated mimoLive to 4.4b3 (I was using 4.3.1.)
Updated mimiLive to 4.4
Updated MacOS to 10.13.6
Updated MacOS to 10.14
Updated all Blackmagic software and firmware
Downgraded mimoLive to 4.3
Downgraded mimoLive to 4.2.1
Downgraded mimoLive to 3.2.1
Made a new mimoLive file at 720p (we’ve always been at 1008p) with nothing but a single placer and output to a single file (ProRes 4222, as per usual).

No joy.


I completely formatted and restored my iMac and then loaded only mimoLive and the Blackmagic drivers. Same problem.

I also used the Blackmagic video capture software configured with the same resolution and encoding settings as mimoLive (1080p/ProRes 4222) and it DID NOT have the problem that mimoLive is having.

So the problem seems to be isolated to mimoLive.

@“Cameron Aanestad” I have tested the 4.4 with a 4k Ultrastudio and didn’t have issues. Can you please do a sample recording and send it to me?

I was having the exact same issue. Currently sitting on 4.2.1 as anything higher than that breaks the sound. We originally thought it was a hardware error, but after finding the exact same thing in a different studio with different kit - concluded it was Mimo. Reverted back to 4.2.1 on both and it works fine. We’re on the road at the moment but if you don’t get the sample recording - I’ll see if I can dig ours up from a few weeks ago.

Actually - found a small clip here from a few weeks back. It’s bizarre. As I said, revert back to 4.2.1 it’s fine again.

4.4 is better but there are still some drop-outs from time to time. The audio doesn’t “freeze” after about 10 minutes like it did before.
However, if I have a camera in a placer and audio in audio only if I then turn on/off the camera(placer) in layers it makes dropouts in the audio only layer…? I’m using Blackmagic Ultrastudio 4K.
USB is still working fine.

@MrAndrewMcLean Can you confirm that its still the same click with mimoLive 4.4?

@“Janne Olsson” Glad to hear that mimoLive 4.4 isn’t doing the audio freeze anymore. We need to check for the audio dropouts. Can you provide a sample recording as well?

Some explaination for your audio dropout when switching off a Placer layer: Internally the device drivers are different for a video hardware with audio, a video hardware without audio and a pure audio hardware. When you switch off the Placer layer the video source will change the device driver from “video with audio” to “audio only” to save CPU performance. This switch could cause some glitches because the device driver is reconnecting to the hardware. You can avoid this by installing a second Placer layer using the same video source. This layer is always live. Switch the option Geometry > Show as > from Fullscreen to Custom and move the video image off screen. This we call a “keep alive” layer :slight_smile: This layer will tell the video source to keep the device driver as “video with audio” even if you switch of the other Placer layer.

So where can I send you a recording?

Here’s a youtube link. Dropouts happens at 0,31 - 1,20 - 1,51 - 2,08 - 2,41 - 2,57 - 3,28 and so on. About every 30seconds between them.

mimolive 4.4
Ultrastudio 4K
Mac OS 10.13.6

I am also having an issue with audio dropouts for our house of worship. Starting out there is no audio dropout, but it progressively starts and ends up getting worse. We are on mimolive 4.4 and while it has gotten better since the previous version it is still unusable for our 2-3 hour service. I double checked that the audio sample rates are the same. I have also checked all of our equipment, and there is no issue.

Additionally I am having an issue where I go to open my saved template files with all of my layers and sources and mimolive freezes and then becomes unresponsive. If I make a new template, it runs fine aside from the audio drop out, but if I save the said template, I cannot reopen it as it freezes and is unusable. I have restarted the the iMac Pro, made sure high sierra is utd, reinstalled mimolive, and the problem still occurs. I might need to just install a previous version of mimolive for the time being.

My Setup:
mimolive 4.4
Atem Television Studio HD
Ultrastudio Mini

@Jordan Thank you for your patience with mimoLive. I’m sorry to hear about the issues you’re having. Those should be addressed in mimoLive 4.4.1. Could you please take a look and see if this indeed is the case?

I will check asap and let you know. Thanks.

Hi Oliver,
Okay - updated to 4.4.1 from 4.2.1.

Click, click, click like before every so often. Back to 4.2.1 for us.

@camsna @“Cameron Aanestad” @MrAndrewMcLean @“Janne Olsson” @Jordan

I really would like to tackle this issue since it obviously affects quite a bunch of you guys. Unfortunately I didn’t have any luck in reproducing this nasty bug on my end. Could you please do the following and send me your results as private messages (to not bloat this thread too much)?

1 In the menu bar Option-click the mimoLive menu and select Debug Preferences.
2. In the preferences window go to the Debug pane and check Enable Debug Mode.
3. From the Audio pop-up menu select Debug Output.
4. Quit mimoLive.
5. Start the Console app, add mimoLive to the search filter text field in the top right of the app window and hit Enter. To the left of the search term you can also open the little tag pop-up menu and select Process instead of Any.
6. Launch mimoLive again and reproduce the issue.
7. Select and copy all text in the Console app.

To deactivate Debug mode, go to the preferences again, uncheck Enable Debug Mode and restart mimoLive.

Thanks for your support!

Here are links to the copied/pasted console log and the video I recorded during the logged session:

Relevant details:
I updated software (mimiLive, all Blackmagic software/drivers/etc., MacOS, etc.).
I replaced my UltraStudio 4K with a brand new one and replaced all of its audio, video, and data cables.
I installed mimoLive and the necessary drivers onto two different computers (including one that I erased just to test the problem – all I installed apart from the OS – 10.13.5 – was mimoLive and the Blackmagic drivers). Still had the SAME problem.

What now?

I re-tested, using a separate audio interface (which does NOT display the clicking/popping/dropout problem). Thought we could compare the logs.

Here are links to the copied/pasted console log and the video I recorded during the logged session: