Some basic FM 6.0b18 queries

I’m usually on here adding my help to questions people have, but now I have a few of my own regarding the latest (and previous) version of FM 6.0b18. There are only a handful of people posting their problems and findings as beta testers, so I’m looking to see if they’re having the same issues. I’m usually sending my beta findings via the Help > Beta Feedback link within the app, but then others (like you) never get to see them.

  1. Are you successful at dragging in a large number of images to the timeline? I’ve been able to drag in sometimes around 200, but I have a China folder with over 1700 images, and an India folder with over 3000 images, and each time I try to add them to the timeline all at once FM will crash. Has anybody tested this and do they get the same result?

  2. If an image (or even a mask) is placed on the stage with rotations of exactly 90°, 180°, or 270° and then the corners or edges of those layers (or masks) are dragged with the mouse, do you get erratic behavior on the stage? The image “jerks” around, and does not adjust in size as expected (or as it would at exactly 0°). Actually, any rotation other than those three work perfectly (even fractional degree rotations).

These are just starters. I know Peter is working hard at addressing the issues we’re finding, and I know “all” aspects of the program should (eventually, we hope!) be fixed before release. But with a bunch of new features having been added (like Map Assistant… for example), and all the new elements regarding image manipulation (B&W, sepia, etc.) and dealing with text, and also the new curves features for Opacity, Animation, etc. I’d like to see some of the “basic” features of the program working solidly before dealing with some of the outlier issues. And it’s highly probably Peter is aware of all of these issues, but can only do so much at once (I really feel for you, Peter!!!)

Personally, I’ve never “shared” any of my slideshows on YouTube or Vimeo or the iPad or iPhone (my wife and I always present our slideshows directly off our laptops via HDMI), so I’m not one to find issues relating to those program options affecting me. But everyone does things differently and uses FM in different ways, so I realize that what is a problem affecting one person will not necessarily impact someone else.

In any case, for at least the two problems I mentioned above, are you having the same findings?

Thanks…Stan

  1. My folders are all divided into sub-folders. I notice that you can’t actually drag the folders to the timeline, just the images within them. I don’t think I have any folders with more than about 500 images, so am unable to test this.
  2. I have no issue with this, if I am doing what I think you are doing:

In v5 I have always added my YouTube slideshows the less direct way, but I tested the direct link and it worked. I reported before that this can’t be done in v6b. And it still can’t in beta 18:


I know Peter has a lot on his plate and I assume FM is pretty much a one-person app, but it would be nice if some of the issues that the few of us who seem to be bet testing this product could be addressed when raised several betas back. This would encourage us to go on. I’m afraid I am reaching the stage where I am about to give up.

Just to be clear, I have always created a folder on my Mac that will hold everything for that slideshow – so that would include images, songs, videos, etc. When I’m dragging images, I am NOT dragging the folder to the Timeline. I link the photos through FM’s image browser by dragging the folder to the top of the Images section, then once the images populate the browser section, I just click and drag down to include all the individual images (not including anything NOT an image), then drag them as a big group to the timeline. I’ve been able to drag about 200 or so, but when that collection gets higher and higher, FM crashes after appearing to start the load – I’ll see the progress bar go a short ways, and then the app crashes. Thinking it might be a glitchy .jpg file, I’ve tried using numerous photo collections, and it always does the same thing. Dragging them in using smaller groupings does work – and FM itself can handle a large number in the slideshow – but getting them all in at once is the issue.

As for the image rotation issue, your attached image doesn’t show what’s going on in real time. Did you rotate the image 90° and then try to move the corner points of the image, or the edge points? Whenever I try to do that, the image gets jerky, and doesn’t anchor the OPPOSITE corner (or opposite side) as would be expected when you try to shrink or enlarge an image. Again, that ONLY happens when the rotation is set to 90°, 180°, or 270° (or even their negative equivalents). Any other angle works perfectly.

I was doing what you are saying with the rotatation. The slide originally filled the stage, with black edges since it is 4:3, and the text box was within it. I rotated the slide 90 degrees, then shrunk it by grabbing both edges and corners. I rotated the text box and moved it to the the left. All was fine.
Are you having this issue because you have 3,000 images in the slideshow? That could be overburdening your system.
I am on Big Sur and I was doing this in a test slideshow that only has this image in it currently.

I have my stage set to 16:9, so I changed it to 4:3 like you have it. Didn’t alter anything. I’m only testing on ONE slide in the presentation (not 3000 – and I don’t believe the number of images within the slide show would affect the scaling of a single layer). What I did try was turning OFF Preferences > Authoring > Snap Layer Edges to Grid. That did allow for smooth scaling, rather than the jerky movements by having the Snap to Grid turned on. BUT – the layer still scales pretty much in the OPPOSITE direction of where you would expect it to. If you scale by moving the top left corner, then the bottom right corner should stay fixed. If you scale by moving the left edge, the right edge should stay fixed. In this case, they don’t work that way.

I’m going to try and make a very short video and post it (somewhere) so it can be seen in real time. But it won’t be until tomorrow – it’s currently late where I live right now.

My stage is 16:9, but it just so happens that the image I had was 4:3. Anyway here’s a link to what I was doing.

Okay, hope this works. I used Apples built-in screen capture and uploaded these to my Public Dropbox folder. The small moving circle indicates mouse clicks and movements.

Here’s a link to a video that shows the erratic behavior I’m trying to describe. Works fine at 0° Rotation, but turned 90° it jerks around and does not scale as expected (opposite corners or edges should remain stationary while the chosen point is moved). Settings are Preferences > Authoring > Stage: Show Grid While Dragging Layers > Snap Layer Edges to Grid is clicked ON.

[https://www.dropbox.com/preview/Public/Screen%20Recording%202021-04-05%20at%2011.18.37%20AM.mov?role=personal]

Now here’s a link to a video with Preferences > Authoring > Stage: Show Grid While Dragging Layers > Snap Layer Edges to Grid is clicked OFF. Notice that the scaling is now smooth regardless of rotation, but at 90° the scaling is still not what should be expected (again, opposite corners or edges from the chosen point do not remain stationary).

https://www.dropbox.com/home/Public?preview=Screen+Recording+2021-04-05+at+11.21.25+AM.mov

Hi, Londinense – I just went back to watch your video again closely and noticed that what I described is visible on your FM stage as well. After you rotate your layers 90° you’ll notice when you click on a corner to scale the image, the opposite corner does not stay in place. At 0:23 on your video you drag from the right edge and the image scales from the bottom left corner. And on the last scaling of your image at around 0:32 you can see the image “jump” or “jerk” on screen.

To me it seems like the original “virtual” corners or edges of a layer at 0° are being used as the focal points to perform the scaling when that layer is rotated to 90° (or 180° or 270°), thus knocking it all out of whack. Again, any other rotations work fine. I’ve tried 89.9 and 90.1 and it works as expected.

I guess it’s not something I noticed, not being anything I’d normally want to do within FM. Obviously if you think it’s a bug you should report it. No doubt you have!

I really wanted to know if others were experiencing the same thing. It’s difficult to find all possible “bugs” if you’re a single user because people use the app in so many different ways and they’ll only find problems if it affects their approach to creating a slideshow.

And yes, I have reported it…