[Quartz Composer] QCJSON didn't appear in Quartz Composer

Hello !

First : My apologies if I’m not in the right category.

I’m new on QC, and I try to make new layers, and for one of these layers, I need to import JSON datas.

I’ve searched on Google for a plugin, and “found” 2 : QCJSON that was developped by Achim of Boinx (or someone else) and “Climb JSON Importer” but didn’t found the website or Git to download.

So I’ve downloaded the QCJSON plugin, put it on the ~/Library/Graphics/Quartz Composer Plugin but it didn’t appear on QC.

Anyone know how to solve this ?

I had the same problem when setting up my environment for building layers. I did not pursue it though as I do not currently have a need for reading JSON data.

Thanks Stimpy for answer me, at least now I know I’m not alone :smile:

As a side note I did find a handy application “QC Plugin Manager” that helps with ensuring that additional Quartz Composer Plugins are located in the correct locations. It does recognize that my QCJSON plugin is installed and in the correct location yet I still do not see any JSON related patches in the library. Might it be that this plugin is only a prerequisite for the LUA plugin and that all of the JSON parsing should be done with LUA?

Achim would already have replied if he wasn’t on holiday this week. He is back next week and I’m sure he will be able to give you a tip.

Thanks Oliver, we’ll wait next week :wink:

It could be that the QCJSON plugin is 64 bit only, so you need to set the Quartz Composer editor app to 64 bit mode (via Finder Info Panel for this app).

All Quartz Composer plugins are always independent so there is no need to install the QCLUA plugin to run the QCJSON plugin or vis versa.

However if you are about to modify layers that were shipped with mimoLive you will need to install the QCLUA plugin because all layers make use of it.

The QCJSON plugin reads in JSON files and pars them already outputting a Quartz Composer Struct for use with the native Struct-patches so there is no need to parse the JSON manually with LUA.

Just to make sure that you didn’t missed it, we have quite some documentation on how to create custom layers for mimoLive with Quartz Composer:


Hello Achim !

Thank you for your response, I already download QCLUA and created new layers ^^

I’ll try to set QC in 64 bits and will come back to say if it works :smile:

EDIT : My QC was already in 64 bits mode, so it’s not that :confused:

UP please

Try to put the plugin into the root /Library folder rather in the users ~/Library . Does this help?

I’ve tried this but even if my account is set to admin (I mean, true admin) and Sierra still say to me that I don’t have right to copy on my sytem folder …

I’m looking to fix this and come back to you.

Thank you for helping me Achim :slight_smile:

I succeed !!!

Not by copying on the system lib, but I downloaded the git files, and open in Xcode the project, then modifying the “version for” to 10.12.

After that, I’ve tried to compil, but don’t really know if that work or change anything, then I go back to list of files (still in Xcode), and right click on QCJSON.plugin and then “Show in Finder” (it open the debug folder), then I’ve copy the file and paste it on the Plugin folder and … It appear in QuartzComposer !

Now I have to try if it work, go back to you to keep you in touch :slight_smile:

(If someone who has the same problem can try, to see if I’m lukcy or I found the solution)