Problem with new Dacast Limelight CDN streaming

Hello,

I’m trying to stream to our new Limelight CDN with Mimo and constantly get RTMP error -1337 disconnects as soon as Mimo tries to connect; I’ve checked the RTMP URL and credentials and they’re good; and I tried over our old Akamai CDN and all is good so looks to be something to do with Limelight.

Can you help me isolate what the cause might be?

Screenshot of what happens in Limelight below:

Test credentials:

Akamai:
RTMP URL: rtmp://p.ep53325.i.akamaientrypoint.net/EntryPoint
Stream key: dclive_1_150@53325
User: 960447
Pass: 961842
Preview link: https://iframe.dacast.com/b/181709/c/568976

Limelight:
RTMP URL: rtmp://6cd433f3-47a3-9142-e358-61c5fc1cfda2.dacastmmd.pri.lldns.net/dacastmmd
Stream key: 322f4c01f6264387aa726fc7b02f8768_4500
User: 945971831
Pass: 8fe97587dfa33d53
Preview link: https://iframe.dacast.com/live/647a4d07-fd98-f70f-bd5a-f046990bb18a/b459be64-a715-9738-a1fa-a0c8fcd63a0e

LMK if you need any further info.

Thanks,

Michael
Senior Solutions Specialist - Dacast

Hi @Michael_Elliott,

It’s great to hear that you’re testing mimoLive for DaCast and thanks for reaching out.

I’ve tried with the provided credentials and see the same issue. Which is good, because at least we can reproduce it. I will ask engineering to look into what error -1337 means and see if we can fix this.

Your service isn’t using RTMPS yet?

Alas not yet Oliver.

Happy to jump on a screenshare if needed next week (I’m based in London but I’m usually available til around 8 or 9pm London time for a chat.

On another note, would it be possible to have an internal testing license for the software to be able to better support our users using your encoder? I’ve only just joined so I have a free trial but not sure if that’s going to become fully inoperative in the next 14 days or so. Would help massively to ensure that any backend changes we make can be tested to ensure compatibility going forward.

Much obliged,

Mike

Hello all… Same problem here with the -1337 error… Waiting on an answer from DaCast. If you get a solution, I’de love to know… Thanks!

@Michael_Elliott Thanks for providing the testing accounts. It turns out that Limelight uses a different login procedure in RTMP than most other streaming services. This procedure isn’t implemented in mimoLive yet but will be in the next update 5.9. Unfortunately there is no workaround for the current mimoLive version.

Thanks for the update @Achim_Boinx - appreciate it and look forward to the next version of mimoLive!

This should work now in 5.9b1 https://boinx.com/connect/mimolive/versionhistory/latestbeta

Can confirm, have tested and is connecting a-OK. Thanks @Oliver_Boinx @Achim_Boinx!