Owner of Foto Magico 5 trying Foto Magico 6 need help

I want to add text to the introduction in a still frame song video I’m working on. When I try to add text with the T icon it says “Double-click to add text here” and only gives me a menu to the right instead of doing what v5 did which was to simply let you enter the text right into the image/screen in the center of the screen.

Can someone tell me how I can add my introduction text in exact? It’s for Youtube slideshows and music.

Currently-released FM 6.1.4 HAS A PROBLEM!

After clicking to Add Text you CAN’T double-click the text box to edit it, although it is added as a layer. I did find a work-around, though. Click on ANOTHER SLIDE in the Timeline to select it, and then click back on the original slide containing the new text layer you want to edit. THEN you can double-click on the text box and make your edits.


Try this: Goto the system preferences on your Mac, select the mouse icon, lower the double click setting and try again to edit the " double-click to edit" text input.

This worked for me and I couldn’t believe such a simple setting made the difference. Good luck to all those that have been clicking away in frustration.

Also a big thanks to Julia that research this and found the solution.

Thanks, digitalsnapper, but a bit late on your response – this was fixed almost immediately in the next version, FM 6.1.5, and works as expected in the latest FM 6.2.1.

Besides, adjusting the double-click setting in the System Prefs might be a temporary workaround, but that affects your mouse settings globally, which most users would not want to mess with if they’re comfortable with a quicker double-click response.

Oh, I am really sorry!, I meant no offence. Its just I was having a nightmare trying to get the “Double-Click to Edit” text input to work but nothing happened. I contacted Boinx customer service who kindly called me and talked me through the Double-Click process, but still it wouldn’t activate. Then my friend Julia suggested changing the mouse double click rate in system preferences, low and behold it worked. I just wanted to share my good fortune with others, thats all. That was my first ever post to a forum, seems I messed that up as well.

No apologies needed. And I’m sorry if I came off a little harsh. It’s just that your suggestion applied to a version that’s already four updates ago (6.1.4 > 6.1.5 > 6.1.6 > 6.2 > 6.2.1). I keep tabs on the updates constantly (at least weekly if not more).

And if you have questions are complaints or suggestions about the app, don’t hesitate to post here. Everyone is a “first-poster” at one time or another. I joined a Facebook group a couple of months ago about a piece of equipment/software, made a comment about it, and got slammed by at least a dozen people!!! It was “supposed” to be a “help group” so I decided, nope, these people were not for me, deleted my post, and left the group.