NDI Problem with 2 Newtek PTZ1

Hey folks,
i already tried to get help through the mimolive feeedback form 8 days ago, but havent got an aswer yet…
So here’s another, hopefully someone can help me here:

We are using mimolive for a couple of month now and are pretty satisfied with the performance so far.

But we are testing for a mobile setup for some upcoming events where we have to go to the customer.
Therefore we bought a setup kinda similar to the boinx setup of the recording live events youtube video.
So we have a macbook pro 2019, a ubiquity unify 8port poe switch and 2 Newtek PTZ 1. Then we have a Presenter Laptop via NDI and a Mewo via wireless NDI.

Long story short, we have a problem with the 2 Newtek PTZ1 since they are not transmitting video at the same time… They work fine in the NDI Studio Monitor, both transmitting Video. But theres only one PTZ working in mimolive, not both of them at the same time…
We tried a couple of things:

  1. We tried DHCP and static IP Adresses
    2 We tried using POE and power Supply.
  2. We tried to connect them with a simple gigaport netgear switch.
  3. we downgraded the firmware of the PTZ to the one on their homepage.

Nothing really worked…
And the odd thing is, every other NDI is working perfectly, we already connected a couple of presenter laptops via NDI without Problems, the MEWO is working fine…
But those 2 PTZ are near to driving me nuts!

Hopefully someone can hint me the direction to the solution!

Thanks, Dirk!

here is a picture of the NDI Page:

Hey, just wanna push this, No One can help me? :frowning:

Hi @xlighting I apologize for the late response. Thanks for using mimoLive!

From your second screenshot I see that the PTZOptics cameras are obviously in a different IP subnet from the rest of the NDI stuff. (192.168.100… vs. 192.168.178…) I think that this is the cause of the problem. What is the IP number and network of the mimoLive Mac?

Other than that, it should work. We also have 2 PTZOptics cameras and both work fine.

Also, please watch the MBP for heat troubles. If it heats up, you may suddenly experience frame drops from NDI during your production. I think it might help to turn of the CPU turbo boost mode, but do not have first hand experience on that.

Hey Oliver,

thanks for your response…

When the Screenshot was taken, the 2 PTZ1 have been in a static IP setup with a NetGear GigaBit Switch, while the Scan Converter and the Mewo were connected with a FritzBox…
But both PTZ1 worked fine whitin the NDI StudioMonitor… So the overall IP Configuration and connection should be alright or am i missing something?

We already tried to setup them all with the fritzbox, but with the same result!

You need to have the cameras in the same IP subnet as the Mac. Not sure what the NDI Studio Monitor is doing to get a picture, but we’re supposedly using the same NDI library. Can you send me a screenshot of the mimoLive sources setup?

Hey @Oliver_Boinx!

So yesterday we did a total restart of our setup, all of them set to defaults and configured everything new. Good thing is, both PTZ are working now, but other problems occured :slight_smile:
So we have a MACBook Pro 2019 6 Core i7 32Gb and Radeon Pro 5300M running Mimolive.
We have 2 Newtek PTZ 1 and one Kiloview Converter connected to a CanonEOS Camera.
All of those are wired to a Ubiquity Unify 8 POE Switch and implemented via NDI into MimoLive.

All are set to static IPs in the same Subnet. IP 10.10.10.X Subnet

The following Problems occur…

  1. If I turn on WiFi the connection to the 2 PTZ is lost after a couple of seconds. If i switch off they sync back, we also tried wired internet with a belkin usbc lan adapter. same problem there.

  2. after some minutes the PTZ cams show artefacts (See Picture) and a slightly growing delay… turning on off resets it for 1-2 minutes and then its kinda freezing again…

We eliminated POE and used a simple netgear switch, same problems.

All the time the Kiloview converter and the eos is working fine. Just the PTZ are driving me nuts now :frowning:
Time is running low, because we have livestream of an event outside of our studio in 2 weeks and im out of ideas.

I really hope you can help!

Hi @xlighting I’m sorry to hear that you experience these issues.

Here is what I would check:

  • Are you running into thermal throttling problems? https://docs.mimo.live/docs/thermal-throttling
  • If this is a 16" MBP, it is recommended to install Turbo Boost Switcher and switch turbo boost mode off. http://tbswitcher.rugarciap.com/
  • Check the Source Performance Monitor for the settings of the source. If you can, switch the camera to the same fps setting as the document. For example 1080p30fps. Also check for dropping frames.
  • If the camera disconnects when you turn on Wifi, it could be that Wifi takes precedence over your wired network connection. Check System Preferences -> Network. The top most network listed should be your wired connection.
  • Also make sure you’ve downloaded and installed the most recent “NDI HX Driver” for Mac from ndi.tv

Let me know if any of this helped.

I’m frequently using multiple NDI HX cameras and full NDI capture devices with the Unifi Switch. If something like you describe occured, it was usually because the computer was overloaded but the MBP you have should be able to handle quite a number of video sources.