Muting or Soloing Audio

I’m currently testing some of the audio functionality of mimoLive. I have audio coming in through an UltraStudio Mini Monitor, being fed the program output of an ATEM Television Studio. The audio source is a handycam connected to input#2 of the ATEM. My goal is to mute the camera audio when I trigger the playback of a video clip in my layer stack. I accomplished this by using the Audio Only layer, setting the Audio Source to the ATEM Program Feed. Then I created a shortcut to trigger the Mute function of the Audio Only layer. This shortcut is the same as the one used to trigger the video clip playback. Now, this works fine––but let’s say I have a dozen different video clips to play throughout the show; it would be much more convenient to have a ‘Solo’ function built into the Placer layer so I wouldn’t have to have a new Audio Only layer for each video layer––or have to manually mute the ATEM audio each time I go to a video. Does this make sense? Or is there some other way to solo a video clip while it is being played?

@“Jason Jenkins” In case your video clips have audio, there is a way to do what you want built into mimoLive. Unfortunately, we found a bug (see below) that currently limits its usefulness.

There is no Solo function built into the Placer layer but kind of a Mute function built into the Audio Only layer. You can configure its ducking effect to behave like a mute switch using the following settings: Threshold 0, Amount 100%, Fade Down/Min Duration/Fade Up 0s. Set the movie source as trigger source. When the Placer layer containing the movie source gets activated, the Audio Only layer ducks its input audio ad infinitum which effectively mutes the layer. Note, however, that silent portions in a video clip will cause the ducking to stop temporarily.

For multiple video clips you would use a playlist source with the Non-Stop option unchecked as trigger source. That way the playlist source plays one playlist item at a time, each time you set it live, while ducking the Audio Only layer during video playback.

Now, about that bug: Placer layers containing a movie source or playlist source cannot be activated more than once while the respective source is set as a ducking trigger source in an Audio Only layer. A workaround is to toggle the Audio Only layer off and on again. But that, of course, is counterproductive when using a playlist source as trigger source. Unfortunately, I currently cannot give you an ETA for a fix.

Another option, if you’re brave enough, would probably be the mimoLive HTTP API that is available from version 2.6.