MimoCaller inconsistent

We’re new to the software so maybe we’re doing something wrong. But we are having a lot of trouble using MimoCaller.
First issue is: quite often the caller has to reload mimocaller url in the browser multiple times before they get video of themselves, or they get video of the remote feed, or before we or they hear audio.
Second: some callers receive an exceptionally wrong delay. Greater then 10 seconds.
Third: audio out form a remote caller is being picked up the remote callers microphone and and echo occurs during monitoring. This is with mix minus on.
I’ve looked at the bandwidth usage for mimocallers and don’t see that as being an issue. I.e. a caller which sounds fine and there is no delay will show the same bandwidth going in or out for both audio and video as a caller who is experiencing a 10 second delay.
We’ve also experimented with MimoReporter on iPad and that needs to be restarted multiple times before we get consistent Audio/Video.

Hi @Davis_Media_Access.

Welcome to the boin forum :)!

Thank you for using our products and for your feedback.

We are sorry to hear that you are experiencing quality issues.

  1. Could you provide the version you used se we can try to reproduce the issue:
    1.1. Browser (with version)
    1.2. macOS version
    1.3. mimoLive version.

  2. Is the video in sync with audio?

  3. This issue occurs when using mimoLive with Browser? (or mimoLiveReporter iOS app?)

One user was Chrome version is 81.0.4044.138, and on our PC, it’s Windows 10 Home, Version 1909, OS Build 18363.836. I had to have her reload the mimoCall in the browser three times before we got her video/audio and she got our video/audio. After which it does seem rather consistent.

MimoLIve Reporter version is 2.4. I have to end call/join call a few times to also get it to connect properly with mimoLive.

With firefox 76.0 on OSX Catalina I’m told there is a 15 second delay on the audio.

MimoLIve version is 5.6 but we had the same issues with 5.5

I too am having the same issue. The caller often has to restart their web browser and sometimes that doesnt even work. The only way I can get it to work properly is when I restart MimoLive. The main problem being the outgoing audio is not being sent from the software. I am using version 5.6 and I ask all users to use Google Chrome.

I tested with the following:

MimoLive 5.5 on Catalina
MimoLive 5.6 on Catalina
Firefox 76.0.1 on Catalina over local, udp separate from the MimoLive computer
iPad iOS 13.4.1 with Safari over local, udp
Android version 9, Chrome 81.0.4044.138 over STUN, UDP via T-Mobile network 4G

First some noise:

  • No matter what there is about a 15 second audio delay in both directions when using mimoCall via Firefox. This is with both versions of mimoLive. I only tested via local,udp but my co-worker intially reported and he was coming if via STUN, UDP.
  • The issue with the video send/return seemed to come down to impatience. I.e. on my phone it would take up to one minute for these connection to negotiate.

What I did find is consistent issues with the return audio to mimoCall from mimoLive. I explored the following:

  • Reloading the mimoCall sometimes worked to get the return audio call. At most it would take 3 reloads.
  • If reloading the mimoCall didn’t work I had to restart mimoLive
  • I investigated if this only occurred on the first or second mimoCall source. Was inconclusive.
  • The problem occurred regardless of which device initiated the call (iPad, Android or Laptop.)
  • Reloading via the mimoCall interface didn’t seem to help any.
  • Half the time I’d start up mimoLive and connect via mimoCall from two devices with no issue. The other half of the time one mimoCall would be fine and the other not. I either had to reload the mimoCall or restart mimoLive to get things working.
  • Once I got things working they worked. Even with frequent reloads of mimoCall.

I got the feeling that the issue is somewhere in mimoLive. Like that it’s not being told that a mimoCall has connected and it should start sending it audio. The outgoing graph for audio is always flat when it’s not working. It does receive the audio/video consistently and that is shown on the graphs. It also seems to send the return video to the mimoCall consistently.

Hope this helps.

1 Like

Thats identical for me and I have had to revert to using Skype via NDI predominantly now.

1 Like

Hi @Mdillon1, @Davis_Media_Access. Thank you for the feedback. It helps a lot because we try your work flows to run into the same problems.

I have been able to reproduce the issue by forcing an audio delay which would prompt a audio restoration mechanism which just won’t work in situations where

the audio restoration process takes more time or attemps to recover. Audio gets out of sync some much that the audio requested is from a far past (more than 5 seconds)

which doesn’t exist anymore. That’s the reason why the audio graph shows no audio output. The “past” audio can’t be fetched anymore and no data is available.

The reconnect basically “resets” the audio time because it resets the audio engine start time.

The good news are that the we have found the issue and that our whole team is analysing the cause and possible repair solutions.

1 Like