MimoCall User Login Issues - 5.10b3


Recently I did a series of recordings over MimoCall for a show. Out of 8 users in the span of last week, I’d say 6 experienced a consistent issue when logging into to MimoCall. After hitting the link, the browser would hang on the “Setup your video and audio devices” screen, where the white circle would perpetually spin.

In MimoLive, I could see that there was a connection to the partner, with outgoing data, but zero incoming data. Multiple reconnections to partner had no effect.

Generally this was seen on Chrome for PC, but I believe some of the users experienced it in other platform/browser combos.

I am wondering if there is any suggestions to help troubleshoot what the issues could be. Generally many of the users I am trying to record with are not super tech savvy, so having them diagnose their issues is challenging. Any ideas welcome!

I was using the beta 5.10b3.

@cass Thanks for joining the forum and for using mimoLive!

I’m sorry about the issues you experienced. Thanks for reporting those. We will have engineering look at the Chrome on PC to see if there is an issue there.

Unfortunately, without access to the PC that has the issue, it is very difficult to figure it out. I think it might be the access to camera and microphone which need to be confirmed by the person using the browser.

@cass Can you please confirm that you were sending them the link to the new web client (the one that has “/beta” in it)?

Also, can you please find out what version of Chrome they were using?

Thanks @Oliver_Boinx for responding! I was using the /beta/ MimoCall URLs.

I realize it’s challenging to troubleshoot. Sometimes restarting the browser would work. I couldn’t detect a clear pattern over the bunch of recordings that I did.

In one case a person went from laptop, to iPad and finally to her iPhone until she was able to get through on the link (she tried on every device and had the same issue). It was odd.

It would be cool to have some kind of a text chat in the browser window as it seems like there is a connection, but no A/V. That could help troubleshoot with them! But I’m sure that is a lot of work :slight_smile:

It looks like a similar issue has been reported on the Facebook Group. See: https://m.facebook.com/groups/302575437740744/permalink/439327490732204/?anchor_composer=false&ref=m_notif&notif_t=group_activity

have similar issues from callers using mimocall beta. they keep telling me they just see spinning circle in chrome. some got it working by going to settings, allow camera and microphone, click the drop down and select if they have multiple devices connected. The issue is that most users does not know or want to bother doing this in chrome since by default, chrome and most browsers block microphone and webcam access and even with a popup, most people just ignore the popup and from there the popup won’t show up again.

The only fix i could think of is boinx should just make a separate app for windows and mac os, Installing an app is easier for most people than going through the browser settings and allow those devices. This is also a security issue since most people might just click on “always allow” therefore a malicious website could just spy on the user anytime.

I actually just got the spinning line problem myself when doing a basic test.

I am using Chrome Version 88.0.4324.192 (Official Build) (x86_64) on a mac (Running Big Sur 11.2.1 and Mimolive 5.10b3)

Microphone and Camera are allowed from a previous test…

clicking the “Reset all settings and restart setup assistant” In this circumstance resolved the issue. Wondering if this spinning line could time out after a certain period and prompt the user to click the link (or somehow automatically restart itself)

Did you simply try to reload the page?

I didn’t … instead just clicked the “reset all setting and restart setup assistant link”

Hi @Kebbel Ah, yes, sorry for the misunderstanding. I meant to say that it should also help to just reload the page.

Also, sometimes there is the need to clear the browser cache. I guess this is done by clicking the link you mentioned.

Also, in trying to re-replicate the issue (unsuccessfully) I also received a “blank” program output. I tried the “reconnect to partner” button in mimoLive, but this did not help. Hitting refresh on the browser did fix this. Here is the screenshot of my chrome screen:

@Oliver_Boinx any update on the two issues… (connecting to mimocall and blank program output on the mimo callers end). Happy to help troubleshoot – I want this to work as close to 100% as possible.

Thanks for offering to help. We are working on a new beta for the web client and will let you know as soon as you can test.

1 Like

That’s great. I’ve had mimoCallers use the beta but had to switch to the pre-beta because of issue like the ones above.

Just curious @Oliver_Boinx , any idea on timelines and once the new version is ready, how will we be notified? (We’re holding off using the Beta for now because of these issues)

This would be super important for me too, any word on a new beta with this fix?

I understand the importance and I hope we will be able to release the next beta of the web client soon.

To clarify, the web client beta and the mimoLive beta are not correlated. The current beta of mimoLive works well and is recommended for everyone running macOS 10.14 or newer.

The mimoCall web client beta is in general working more reliable than the old web client except for that rare initial failure to properly connect. This seems only to affect certain browsers at certain versions and is therefore difficult to track down. A reload of the page usually fixes the issue.

Of course we are working hard at fixing this problem, but you should use the new web client despite this as it generally delivers better performance and more reliable connections (once they are established).

Hi, @Oliver_Boinx. Just wanted to add that we had been having this same issue - MacOS Catalina with latest Chrome browser, so had been giving clients/interviewees the pre-beta link (just taking out the word “beta”). We tried again today, and the connection still does not work smoothly with the link with “/beta” in it. Thanks for addressing as soon as you can.

@Oliver_Boinx Just wondering if there has been any progress on the mimocall beta? The user interface and user experience (when it works) is far superior to the current (non-beta) but we can’t use the new interface until it’s reliable.

Hi Kebbel, Thanks for your patience. The issue is not as easy to pinpoint. I hope we’ll make progress soon.