Mimocall Echo Cancellation


Is there a way to force echo cancellation “ON” at the callers end. I have events with thousands of viewers and 4-5 speakers and all works perfectly fine as long as no one accidentally sets this setting to “OFF”. We had one issue recently where one speaker who was waiting for his turn was fiddling with his settings, set it to “OFF” and all other speakers had terrible echo.

Is that possible?