Mask issue in 6b

In v5, when you select Mask<Rectangle, it creates a mask of the image that is highlighted, no matter what its dimensions. You can’t do this at all in v6b, as far as I can see.

I’ve noticed and mentioned that previously as well. As SOON as you click on the Mask sub-option for an image, the mask should automatically size to the image size. It currently seems to immediately default to the stage size. Or are you saying when you click on the Mask option that the mask doesn’t even show? Your second image shows the “switch” set to Layer (not Mask) so it’s hard to tell if there is a mask there at all.

I’m finding applying a mask to a layer is currently kind of a messy operation (in v b17). Sometimes it shows, sometimes it doesn’t. The newish mask feature for Text, when I tried it, was really wonky.

Masks in FM 5.x worked as expected. I think masking in 6.0 needs some tweaking.

Yes; in the second image I guess there are two layers. But it selects the entire image in v5, even when there is just a single image in, say, 4:3 format. In 6b, you click on Mask and get the drop-down, as shown in my first image. Strangely, there is the option of None (when the image has no mask anyway), and all sorts of options that appear fairly useless — to me at any rate. But no option to set entire image. That’s what should be at the top, not “None”. In v5 there is a choice of rectangular or oval.
I also see there is a Mask box in the Text mode. It doesn’t seem to have anything to do with text. But, as you say, the entire Text function needs work. I can’t create a slideshow yet in v6 to suit my style, simply because I can’t make the background to a text layer opaque!