MacBook Pro M1 Pro 12.7.2 Monterey & Elgato CamLink 4K Sound Fail

Tested my Livestream prior and the audio from my Canon XA 60 seemed to work.
Arrived at soundboard for event to get live feed and while it reached my Camera it would not pass through to mimoLive then to my YouTube stream.

I tried opening my Mac Sound Inputs and Outputs with no luck.
Then my Audio Devices with no luck.
Had about an hour and or more to figure it out and my Mac Mic would show up in my computer so I finally had to panic and switch to OBS last minute with the client waiting and starting 3 minutes late using Mac Mic to capture overhead speakers.

I’ve had luck with mimoLive a few times and it’s glorious but can’t understand the multiple times it doesn’t work when moments or hours prior it fails. This was a high profile stream and I promised 2 cameras, graphs and titles and had to go with a basic one camera zoom in and out with nothing extra.

Been with mimoLive for almost 10 years and feel like I know what I’m doing, probably not 100% as with more “do it yourselfers” and employees using cell phones or web cams I’ve had a downturn but curious why the audio didn’t come thru program? Earlier when testing it worked. Saved settings and arrived at event and at one point I saw something about program muted but fixed that.

I’m unsure the next day if screenshots help or recommended? As I tried so many things these may not help but who knows?

I am deeply sorry to hear about the troubles you’ve experienced with mimoLive. Unfortunately, it’s hard to pinpoint exactly what may have caused the audio dropout after the event. Below, I’ve outlined some steps to check the audio; I understand you might already know this, but I’m including it for completeness and in case it’s helpful for other mimoLive users reading your forum post:

  1. Has the Output Destination selected the correct audio mix? In your screenshot, it appears that you chose the “Program Mix,” which seems totally fine.
  2. Does this mix have an audio signal, or is it just silence? For the Program Mix, you can check the audio meter below the Program Out view in the upper right corner. Typically, this meter will show some level of noise at all times.
  3. If there’s no activity on the meter, you’ll need to examine the layer stack to see if any of the layers carrying the audio are live, or if the volume dial for that layer is turned down.
  4. The volume dial on each layer also displays the audio level and should usually show some noise. If there’s no audio signal, then the audio input source needs to be checked.
  5. Does the audio input source have an audio signal? Is the gain control set correctly? Is the proper Audio Device selected?

Essentially, I recommend tracing the audio pipeline from the output back to the source to identify any disconnects.

However, if the Program Out already showed an audio signal and the audio selection of the Live Streaming Output Destination is set to Program Mix, but there still was no audio at the live streaming host, then this might be an unknown bug. In such a case, we would need to investigate further.

To ensure that I fully understand the situation and can provide the most accurate assistance, could you please describe the steps you took during the setup and troubleshooting process in a bit more detail?

Even simple descriptions or bullet points of what you did and what you observed can be incredibly helpful. We want to make sure we understand your situation completely so we can offer the best possible support.

Thank you for your patience and cooperation.

Hi @SCACtv I went through Shasta last February :slight_smile: (see attached picture of I-5 that day).

I wish I had known about Shasta TV! I would have loved to meet. Maybe next time.

Further to Achim’s suggestions, do I understand correctly that you send the audio through the camera and the Camlink into mimoLive? In which case it would be helpful to see how you configured the Source. Is there an audio signal at the source? Can you provide me with the complete mimoLive document so I can check if there is a misconfiguration? What version of mimoLive were you using?

And maybe by chance/mistake the Gain was set to 0 at the sources?