Lightroom Library not showing in Fotomagico 5.0.6

When I go to produce a new slide presentation, the panel on the right side does not show my Lightroom library. I have checked that the section is ticked in Preferences and iPhoto and Aperture libraries show up if I tick them. And if I tick a new folder then that shows up but not Lightroom libraries. Any ideas?

I’m having the same issue.

I have FotoMagico 5.1 and Lightroom is not coming up for me either


Any news on this? I am only beginning to use Fotomagico and I have the same or similar issue. Lightroom libraries do appear for me in the UI, however I cannot actually do anything with them. Not all folders or collections appear, and no photos at all appear. In other words, the library window is not fully populated with my LR structure when I try to open folders or collections, and the window between the libraries and the Search box with text ‘0 images’ next to it remains blank.

I am running Fotomagico Pro 5.1.3 and Lightroom 5.7.1 on OS X 10.11.6. What I want to access from Lightroom at the moment is all on the local drive. I have photos also on a network drive, however the library files are all local.

Brief update. Interestingly, more folders and collections have started to appear, and now there are also photos in some of them! The structure is still not fully populated, and some folders and collections appear empty. Everything seems more or less random, but the number of photos may have something to do with this behavior. For example, a collection with 20 photos is likely to show them all while a collection of 200 photos is more likely to appear empty. Introducing a new folder or collection in Lightroom generally gets picked up fairly quickly, but there is some randomness to this as well. So, it’s not 100% LIFO. This is really weird.

I can reproduce some of those issues here and will investigate the problem.

Since FotoMagico does not use the original raw files, but the previews that are rendered by Lightroom, it greatly depends on the availability of those previews. Until we can figure out the source of the problem, I suggest the following workaround:

  1. Select the desired photos in Lightroom and export them to a folder of your choice in JPEG format at full size.

  2. Drag this folder to the “Images” browser in FotoMagico.

  3. Use the exported images from there. That way you will be sure to get full size images, and not some reduced size previews that Lightroom might have rendered.

Okay, some more findings: FotoMagico relies on the previews that are rendered by Lightroom. To make sure that previews are available, do the following two things:

  1. In the Library module of Lightroom, select the menu command Library > Previews > Build 1:1 Previews.

  2. Open Catalog settings in the Lightroom Menu, and in “File Handling” make sure that “Discard 1:1 Previews” is set to “Never”

After this the problems went away on my machine. Hope that solves the problems on your Macs as well.

Thanks, this makes sense.

I think I will rather start a two-step process: I will use specific preview builds in Lightroom when initially planning a slide show, and will then discard those and export all the shots I actually wish to consider and use for the final show. As my libraries are fairly massive, it is more practical for me to put some limits on Lightroom. On the other hand, offline backup of all the project files at full resolution is really not an issue. It’s anyway important to understand what is going on.

I have the same issue - problem. It doesn’t show any libraries. And I can’t export and drag and drop image folders either. ;-(

@MagicLeo Have you tried the solutions suggested by Peter above?