Lightroom catalogue not showing after updating to Adobe CC 2018

I used to work with my Lightroom catalogue in FM.

After updating all my Adobe Apps to CC2018 there’s no Lightroom catalogue showing up anymore in FM.

Tried to uncheck and check the option in the preferences, restart everything etc. no luck, no catalogue.

Now there’s Lightroom CC and Lightroom Classic CC. The latter one asked me to update my catalogue after the update. Maybe FM cannot read this updated catalogue?

Anyone else struggling with this as well or having a solution?


I’m having the same issue with Adobe Lightroom Classic CC. An update is urgently needed.

@“Andreas Lattner” @“Daniel Krähmer” Thank you for reporting this issue. Engineering is investigating and we’ll release a fix as quickly as possible. Thank you for your patience.

Same issue here. There is a warning saying that my LR catalog is associated with LR version 6 but has an incompatible version. I am using Lightroom Classic CC.

@“Andreas Lattner” , @“Daniel Krähmer” , @mpezolet We just released a new beta that should solve this issue. Please can you download it here ( ) and give feedback on how it worked for you? TIA!

It does not work for me. I know have two warnings: one for LR version 6 and one for LR version 7. I don’t have access to the LR images.

@mpezolet Can you please send us a screenshot?

Attached are two screenshots, one for the lower Lr icon in the Libraries that seems to be associated with LR-6 and one for the upper Lr icon in the Libraries that yesterday gave an error message similar to Lr-6 but for Lr-7. Today, maybe because I shut down Lr, the upper Lr icon shows two folders, one for Lr folders (Dossiers in french), and one for Lr collections. However, both folders are empty.

Update. I shut down both Fotomagico 5.5.3b1 and Lr Classic CC. If I open Lr first and then FM, I see the Lr Folders and the Lr Collections. I don’t see the pictures in the folders, but I see the pictures in the Collections. If I open FM before Lr it does not work. See the screenshot below.

Now with FM 5.5.3 getting this error when attempting to see my LR library within FM.

I also get a similar error message in German:

The same problem also with version 5.5.3

Now with FM5 5.5.3 I must open Lightroom before I open FM5 and keep it open as long as I am working in FM5. If I close LR and change folder in FM the photos do not show up!

I can confirm what Paq_Den said just before

@mpezolet @“Gastón Sánchez Cano” @“Daniel Krähmer” @Paq_Den I’m sorry about the inconvenience you experience. We’re using the iMedia framework for access to media files and the developers who are in charge of Lightroom integration are working on the issue. It seems that several factors make it more difficult than it used to be. I hope we have a solution soon.

Boinx folks - Any update about the Lightroom integration issue? Thanks

Any update on the LR integration issue? Or is this something you guys just dropped the ball?