Foto Magico 6.4.3 -Undo button not working, I NEED A SOLUTION ASAP?

I recently just purchased fotomagico 6.4.3 and i am having major issues with the undo buttom. it does not work, and as a beginner this is becoming extremely frustrating for me.
I can see this is a problem for others as well but I still have not found a solution.
Please help to resolve this issue ASAP?
What should I do?

Hi @definiphotography Thank you very much for purchasing FotoMagico. I’m sorry about the troubles you experience. We’ve not heard anyone else reporting the undo button not working. What language are you using? What is the key combination in that language that should be “Undo”? Does the menu command in the “Edit” menu work?

I am English from the United Kingdom.
I have tried clicking the undo bottom on the edit tap above but it does not respond

If you type in the seach menu undo not working it will come up with some other people whi have had the sam issue without a solution. I am unable to use this app because i am a new user and hust learning undo is very key. Please i need a solution Asap or i would like a refond

Please can anyone call me i tried to unistal the app from my computer so i can then reinstal it again inhioes of the undo botton wirking and now. I cant even find the application on my computer to reinstal

My phone number is

I have now some how reinstalled the app from the websidte and now the undo and redo botton is grayedout

Pease find a solution or refund me my subscription fee because this is simply unfair because i am not able to use your application properly.
i need resolution now please.
is there no one i can call or can someone call me ASAP
MY NUMBER IS +447791443858

Hi @definiphotography I’m really sorry about the issues. Can you please download version 6.5.1 and check if the issue persists?

The only time the Undo and Redo commands are greyed out is if there isn’t anything to undo or redo.

What did you do before that you wanted to undo?

Also, if it continues not to work for you, we will of course refund the subscription.

Since you purchased on the Mac App Store, the procedure for requesting a refund can be found here:

Yes i most certainly did update the downloaded version to the 6.5 and that is exactly what you have on your website the latest version. Yes i am doing several things on Fotomagici hence my extream frustration when i cant even use the undo bottons or tapvor short cuts, i event went to the setting section to see if there is anything there that can help, the only thing i found was that i can change the amount of times i use the undo botton.

If you cant help me i would like a refund because it appears you have no solution and i am very upset because i spent alot of time reseaching this app and was very expectant with great anticipation only to be let down.

This is super unfair and extreamly frustrating

Please see Request a refund for apps or content you've bought from Apple – Apple Support (UK) on how to request your refund.

can you try to provide a solution?

We’re working hard to resolve any bugs reported as fast as possible. But it requires a bit of patience on your end and your help.

In order to fix an issue, we need to have a reproducible case. Please tell me what steps you are taking in FotoMagico and at what point the Undo becomes unavailable.

I have requested this before is there any chance of recieveing a phone call, this would make the process a lot more smoother and faster? I have left my phone number with you.

When i start using the program, then i add the images and i might just have rotated an image in the wronge direction and i want it back to how it was, when i try to click undo the area ia grayed out, and when i try using the short cut keys comand and z it dies not respond. Nothing happens.

In every instance when i make a mive i have to manually rectify it by deleting and starting all over again

From your forum and the images i forwarded to you this has happened to someone else before, how did they resolve it?

I’m really trying to find out under what circumstances the Undo doesn’t work, but whatever I do to a slideshow, I can always Undo/Redo it.

The only time the commands are greyed out like in your screenshot is if I create a new slideshow or open an existing one. This is because the steps taken aren’t saved to the document, so when the program is restarted or a new slideshow created, there isn’t anything to Undo.

The other people you found on the forum reported very specific cases when Undo wasn’t available. Sometimes, an action is not undoable, like exporting a slideshow, in which case the undo chain can break and undo of older actions may no longer be available. This, however, is certainly the exception. I will ask engineering tomorrow to find out if there are know cases of when Undo becomes available.