ESC button and fullscreen output

Hello! I just discovered that pressing the ESC button disables (switches off) fullscreen outputs – no matter where the keyboard focus is. That’s pretty annoying (and scary). Is that behavior intentional?

Of a preview window, or as an output destination also? (I have no second monitor currently for testing.) When I do this on the same Monitor, yes: ESC brings me back to the main Window.

It’s a pity. I don’t know a way to avoid this. It’s a feature by macOS (It would be strange if a software dev would be able to override this important key). At the settings, there is no option for changing the ESC function.

I’d suggest to output with a BMD mimi Monitor, which supports SDI and HDMI the same time.

Hello @JoPhi, I don’t think that would be related to macOS behavior. If I have a YouTube video playing fullscreen on monitor 2 and I press ESC while browsing with another Chrome window on monitor 1, nothing happens. I guess this is a mimoLive behaviour.

You could turn on Kiosk-Mode


@JoPhi I don’t think the Kiosk Mode would help me.

@Oliver_Boinx is there any way to prevent the ESC button from disabling the full-screen output?

Why not?
Dfine the"outgoing Monitor" as “main Monitor”. Isn’t it about capturing the monitor with HDMI? Whatever the future brings: Maybe you can use it as a workaround. Who knows, maybe BOINX decides to bring in an option to select the outgoing Monitor at Kiosk Mode and/or to override the ESC-key (at least as an option at the settings, as default this would honestly destroy my workflow). And maybe the Kiosk-Mode will get an additional option “Ask me when something is to save.”

Bildschirmfoto 2021-04-01 um 21.08.15

Beides: When you have no chance to close the window, this could be a hard problem. Yesterday, I lost the window-border of the preview. I wasn’t able to close it, 'till the end of the session. And it was overlaying real important things… :smiley: :smiley: :smiley:

I can solve my issue using Keyboard Maestro. I created a macro that does nothing when I press ESC and a macro that sends an ESC to mimoLive when I press CMD + ESC. So, there’s a “clean” way to fix that issue, without having to enable the Kiosk Mode. But it is still not as clean as it should be. If I have a full-screen output on a second monitor, I think the ESC key should do nothing.

WOW, never thought that Keyboard Maestro is allowed to override the ESC-Key for the whole system.

Hope, this will come true for you.

I don’t know if KM can override the ESC behavior for the whole system, but I’m sure it can when mimoLive is in focus (I enabled that macros only for mimoLive).

1 Like