Errors When Saving

I’ve been using FotoMagico for ages with no problems but I’ve just tried to start a new slideshow and it’s refusing to save the file.
I’m saving to a sub-folder within “Documents” on my iMac’s internal drive. The drive has 322Gb free.
All I’ve done is drag 86 jpeg images (total size just under 45Mb) into a new project and try to save it.
OS X 10.9.3 running on an early-2009 24 inch iMac.
My last slideshow is dated 4th April, so I think there may have been a FotoMagico update since then (running version 4.4.4.)
I’m initially getting a warning about drive performance, then a message suggesting there’s not enough space or permissions are set incorrectly. However other applications can save to that disk location with no issues.
Any ideas?

Normally FotoMagico should be able to save there just fine, it could be though, that (thanks to sandboxing), OS X denies FotoMagico the permission to write to this directory for some reason.

Can you please try this: Open /Applications/, click clear display and then try to save again in FotoMagico. This should generate some logs in Console that hopefully help us figure out why it doesn’t work.
Please save the logs and either post them here or send them to if you don’t want to share them publicly.

If you send them to support, please mention they are directed towards me and mention this forum thread including URL (

Thanks, Bastian. I saved the file to an external drive then copied it to where I wanted to save it in the first place. Now FotoMagico will read it & save changes to it with no problems.
I’ve tried saving a new file but the problem won’t reproduce itself, so I guess it’s just one of those things! I’ll have to wait & see if it does it again.