Did skype disabled Mimolive virtual cameras?

A Skype update just came out.
Did Skype disabled mimolive virtual cameras?
Really?
I’m the only one experiencing this?
Anyone knows how to fix it?
Thank you,
Francesco

Thanks for the heads up! I was going to upgrade and glad I havent now! :smiley:

Hi @bandian and @Mdillon1. Thank you for using mimoLive and the feedback.
Just tested it. It seems they dropped support.
Skype version 8.59.0.77 - Has virtual camera available (used from mimoLive).
Skype version 8.60.0.76 - Does not have virtual camera available (used from mimoLive).

There are unofficial websites from which you can download older versions (on your own risk):

  1. https://skype.en.uptodown.com/mac/versions
  2. http://www.skaip.org/skype-versions

The Skype release notes did not mention this change and have not been updated yet:
https://support.skype.com/en/faq/FA34778/what-s-new-in-skype-for-windows-mac-linux-and-web

Looks like all conferencing softwares are removing access to virtual cameras, see https://github. com/johnboiles/obs-mac-virtualcam/issues/131 Is there any performance issue if we use a USB connected HDMI recording dongle, like the Magewell USB HDMI capture or the Elgato Cam Link instead with mimoLive?

There is a fix which can be used with all the apps: Remove the developer signature.

Download Xcode and then go to the Terminal and use this command:

sudo codesign --remove-signature /Applications/appname.app/

1 Like

Nope, sorry this doesn’t work. It works for Zoom not for skype :frowning:
The only thing that worked for me was downgrade skype to previous version.

We will change from virtual cam to an HDMI solution, where we use a Magewell USB converter, but perhaps this will work for you:

codesign --remove-signature “/Applications/Skype.app/Contents/Frameworks/Skype Helper (Renderer).app”

I would say it’s more of a short-term hack than a fix. Removing code signed signatures is hardly a good thing to be doing, in general. I certainly hope that there will be a proper long-term solution that doesn’t compromise security, but maybe that is wishful thinking…

Again, only for my understandings, is there any issue to use a usb connected hdmi to usb converter as a replacement for the virtual camera. Because as I understand, there will be no short- or mid-time solution for this on the Mac platform as this depends on Apple to to enable a more secure way to implement virtual cameras.

What is the command for GoToMeeting?

Hi @Tschens_Jaeger.
For GoToMeeting it would be:
sudo codesign --remove-signature /Applications/GoToMeeting.app
or
current version:
sudo codesign --remove-signature /Applications/GoToMeeting v10.9.1.app

I think it would depend on how the particular USB adapter presented itself to the system. For example, the Blackmagic Web Presenter and ATEM Mini (Pro) all work as they appear as USB webcams. But UltraStudio and Decklink products don’t work without removing the code signature, as they are not ‘webcams’.

Hi Nasi, yes, I’m aware of this, as the USB connected Magewell works and the Thunderbolt 2 connected Blackmagic Design Recorder not. But my question was more related if we get any negative side effects if we replace virtual cam by a hardware dongle solution, eg. performance issues or anything else. Because, if not, I can live with replacing virtual cam by this USD 250 hardware solution.

It basically depends on if the device uses the Apple UVC driver or if it needs it’s own driver.

The UVC driver is not very great and causes more load on the system than would perhaps be necessary.

So you are planning to play out the program output through HDMI and capture it again on the same computer? That will also add latency.

That’s the idea, to show the external Skype caller the current live program. Of course there’s a latency, but audio is routed directly and video should be only visible to them to follow the progress of the stream. So, we tried with Facetime before and it worked. Hope with Skype too.

Sorry. Doesn’t work. The second option will not work, because the terminal cannot handle it. Anyway, the mimolive virtual camera doesn’t show up in GoToMeeting in the webcam popup. The plugin is still in the DAL folder. Any other ideas?

You need to have Xcode installed.

That was done and not the problem. It needed a restart of the OS. Now it works. Thank you.

Zoom now requires v5 to use their service. Zoom 5.0.4 adds back most virtual camera inputs to Zoom … but mimoLive’s virtual camera is still not working. I started a new thread to focus on this problem.

Hack for Zoom 5 with MimiLive