Crashing During Live Streams

I have been having a weird issue for the last few weeks. While I do not think it is MIMO causing it, I am hoping others may have experienced and solved it.

What is happening is, when I stream live, all of a sudden, the entire computer freezes. I have to press the power button and hard-reset the computer. This DOES NOT happen if I record, instead of going live.

This is also happening when I export a video out of Final Cut, using H.264… exporting ProRes does not cause the crash. It seems to be related to H.264 encoding.

Anyone else seen this? Any workarounds?

May I ask some details?
• Version of mimoLive?
• Hackintosh or Mac (which Mac, About this Mac, everything except the serial no.)
• Any error-reporting by macOS? (Please have a look to console.app)
• Any screen recording(s) inside of your document (window capturing)?
• Any RAM-optimizers or other optimizers installed?
• Is any backup software running the same time?

That would have been smart :slight_smile:

iMac Pro 2017. 8-Core Xeon W, 32GB, Radeon Pro Vega 56 8GB
macOS Big Sur 11.2.3

Latest version of MIMO (been happening for a while - Currently 5.10)

No optimizers
No backups running.

I have gone as far as factory resetting the machine with a clean install… same issue in MIMO and FCP… again, ONLY seems to be when doing an H.264/5 Encode

• Does it work when you close mimoLive and when you switch off background rendering of FCP?
• Did you install any plugins for FCP?
• Did you do all of this? Resolve an issue in Final Cut Pro - Apple Support
• When you use ‎1-Click Video Converter im Mac App Store to test-convert a video to h264/5, does it also freeze?

BTW, 1-click-video-converter got several options h264 (mp4) / h264 (mov).

Background rendering on or off seems to make no difference. Tried with a clean fresh FCP (no plugins), same issue. Not sure what you mean about with MIMO Live closed.

I have done ALL those things on the support page, and a whole lot more, same result.

It seems I am not alone. Found a thread of others having the same issue, including exporting H.264 from Premiere. I have NOT seen this happen yet in Adobe Media Encoder, ScreenFlow. Haven’t used 1-click VC.

A theorem:
When h264 (mov) crashes and h264 (mp4) does work (or vice versa), then there could be a bug with the graphics drivers. You could switch on mimoLives debug mode to switch on/off the hardware encoder, to test if this helps (as a workaround):

Just type “Debug” at the help window. Activate the mode at the so called “Debug preferences”. Quit mimoLive and reopen it. You’l get a new menu called Debug.

I hope this helps to proceed with mimoLive. If there is realy a bug, please report it to Apple: https://feedbackassistant.apple.com

I was hoping there was a way to do exactly that, as I think that is the reason.
However, I hit ‘debug preferences’ but nothing happens, and I don’t see that debug menu

Did you restart mimoLive? (a simple close does not work: quit and open it again.)

Quit and opened it a few times. No debug menu

Another way: Open this menu, hold the “option”-key and select “debug preferences” from the menu. :slight_smile:
Maybe I should have mentioned to click the found result.

Inside the Debug Preferences you’ll be able to activate the debug mode.

That seemed to do it! I have the prefs now

Fine. Now, enable the checkbox and restart mimoLive. (quit and open).

Afterwards, continue here:
Crashing During Live Streams - #6 by JoPhi :slight_smile:

@Ray_Lane, please let me know if it worked for you.

Thanks. Doing a test stream now…

You’re welcome. This is now on CPU-load, but if it works, it’s a nice workaround. :grin:

It is still streaming… And re-affirming what I thought the problem might be, but had no idea how to disable :slight_smile:

Sounds amazing! Don’t worry about it. I’d suggest to report this bug to Apple, so it will be solved some day. Hopefully. :slight_smile: https://feedbackassistant.apple.com

Now I wonder if it is the Apple T2 encoder or from the graphics card?

You could switch on the hardware encoder again. Afterwards try it with https://boinx.com/connect/mimolive/versionhistory/5.10.1b3 - some T2-issues were solved. Do you use a USB audio-interface?

5.10.b3 is actually the one I have now that was still failing with the hardware on. I do use a Yamaha USB mixer interface with my RE20 mic, etc.

I did not know that. I thought you were using version 5.10.

I’m happy that the workaround works.

Ps: 5.10.1b3 or 5.10b3 ? :), @Ray_Lane ?