corrupt files...

i’m using Fotomagico 4 and I’ve had file corrupt twice now. this ususally occurs when i’m replacing a media file. i will control-click and image in the timeline (i’m using a mac) and after replace an image by selecting FILE > REPLACE MEDIA FILE. after doing this a few times i will go to control-click the next image and FILE is no longer an option. at that point i save, quit and relaunch the application. about half the time this happens the file i just saved makes Fotomagico crash when opening. over and over. i’ve tried restarting as well. any help would be greatly appreciated.

Please contact support(at) with a crash log attached to the email referring to this forum post. From a crash log we can see a bit more whats happening. Btw: Did you test this with the new version 4.0.3?

i’m using 4.0.1, i purchased this on through the App Store on my mac. no updates available here. definitely regretting having purchased the application by this method, the update from 4.0 to 4.0.1 wasn’t available on the App Store for sometime after it was available on the Boinx website. this appears to the be the case again, 2 weeks and still no App Store update.

Say thank you to Apple and their stupid app store review process which is another word for censorship.
This has nothing to do at all with Boinx.

Boinx sent me a download key for the latest version of FotoMagico so I no longer have to wait for Apple to approve updates. This is awesome, and the new version (4.0.3) seems to have solved the problem of my corrupted files. Thanks Boinx, anyone reading this DO NOT PURCHASE APPLICATIONS THROUGH APPLE STORE