Can't get remote for iPhone to work

Hi all,

I have tried repetedly to get the remote to work. Having enabled remote in the Preferences, checked that both my Mac and the iPhone are at the same network, started the full screen playback aned chosen the iPhone remote option, but the startup screen on the iPhone with the instructions just stick. Nothing happens, and the buttons at the bottom of the iPhone screen are not active.

Any suggestions?


I can’t get Fotomagico Remote to work on my iPhone any more, either. Same sequence. Is this new with the Fotomagico 3.7.6 update? Because I sure didn’t need any of those features nearly as much as I need Remote. Or did Apple kill it with an iPhone OS update? It worked perfectly a couple of months ago. Mac OS 10.6.7, Fotomagico 3.7.6, iPhone 3G running 4.2.1.

I tried resetting the Fotomagico iPhone Preferences. My impression is that the Fotomagico software is not connecting to the iPhone. I think Remote’s computer to computer network is recognized by the iPhone because it shows the correct IP address.

It just re-checked with 3.7.6 and it works fine here,
please make sure you don’t have any firewalls running. Can you please install and see if you can detect your machine and the FotoMagico service.
If that doesn’t help, try setting up an Ad-Hoc network on your Mac and join it with your iphone. You can find an explanation over here:

Hi, same issue here with version 3.8.2., OS X 10.7.2 and iPhone 4S, FotoRemote V 1.1. The Discovery Bonjour Browser on the iPhone shows the FotoMagico service, including the correct name of the slide show, but when starting the FotoRemote, the busy wheel on the iPhone shows up a very short time an then disappears and there is no reaction on the iPhone buttons.
But when starting FotoRemote before FotoMagico is active on the MacBook Air, the busy wheel on the iPhone is running all the time, until I activate iPhone Remote in FotoMagico. After activation, the busy wheel on the iPhone disappears again and nothing happens.
Can you please give me a hint how to make the remote control running?

Thanks, fritzkurt

…aaand, once again, same problem here. Haven’t used FotoMagico for quite a long time, and now updated all components (FotoMagico 3.8.5 Pro on OS X 10.7.3, MBP 17" Early '08 w/ 30" Cinema HD Display, FotoRemote 1.1 (current version) on iPhone 4 with iOS 5.1.1).

Discovery Bonjour Browser shows FotoMagico Service with the correct slide show name.

Busy wheel in FotoRemote spins for second, then it says I should select “Present” etc. — but regardless of order I start the show (“Choose” button) resp. launch FotoRemote nothing happens anymore.
I already unset the PIN I used last time.

What to do??

Thx in advance.

I’d like to re-animate the thread. I’ve tried again, including the variant with the ad-hoc network, both with and without a password. I can ping the iPhone from the Mac, and I can also see the Bonjour entry on the phone, but the two program seem unable to talk to each other. Today I also completely removed and re-loaded the iPhone app from the store before trying again.

Any help greatly appreciated.

For what it’s worth, this solve the problem for me - and I only mention it because I spent a few hours on it…


I just upgraded (via direct purchase on the site, not via the Mac Store) from iStopMotion 2.x to 3.x - I don’t use the program very often, but I had a new itch and I was excited about the remote camera support. It basically worked fine all day yesterday, but no joy today. I would launch the app from Launchpad, just like I had several times yesterday, but it wouldn’t see the remote camera.
I was able to verify via bonjour browser that my mac could see the remote phone camera app.
I had the same problem when trying to get the mac to see the remote camera on my iPad instead of my phone.
I downloaded iStopMotion for iPad (you’re welcome Boinx). The iPad version instantly saw the remote camera on my phone - yeah.


Worked yesterday
Didn’t go through Mac Store
Had been recently using iStopMotion 2.x
Works on iPad (or other computer)


For some reason, launching iStopMotion from LaunchPad was now running version 2.x instead of 3.x, aaannnd, 2.x doesn’t support the remote camera.


I apparently hadn’t installed it completely yesterday and Launchpad was too clever, by half.

So - the lesson boys and girls, is to make sure you are running the right version.

Man, I hope this helps somebody else, because it is sort of embarrassing to write about

BTW - I know the thread is about FotoMagic, but I came here searching for ‘Bonjour’ and I suspect, for some people, the solution is still relevant.