Cannot locate Aperture files in media Browser

Hi there.

Just purchased FotoMagico 4.2 for use with the latest version of Aperture.
Unfortunately, in the media pane of FotoMagico, I get an error that the Library is missing (see attached).

I have the iLife Sharing Pane selected in Aperture correctly. I’m using a 2012 Mac laptop (10.8.2) with an internal SSD Drive where Aperture is installed. The Aperture Library resides on an 2nd INTERNAL drive.

I tried setting up a 2nd Aperture Library, pointed Aperture in the new direction, and still no luck. I’ve created a test library on the primary drive.
Still the software cannot locate any pictures. It sees iTunes music fine but no pictures.

Any suggestions?

Could somebody from boinx please respond. I have not been able to use this software since purchasing this. I have sent 2 emails with no response from the company as well.

It appears to be a sandboxed error according to console. I’m running the latest version and its the direct version. I.e not from the Mac App Store.

Sorry for the late response. (Did you send your support request via email to support(at) We don’t have a ticket for your email address)

Can you post the sandboxd-messages from the console log you mentioned? Maybe those give us a clue where the problem could be.