server location

I have been experimenting with mimoCall running in mimoLive, and I’ve hit a stumbling block.

The only relay server appears to be located in DigitalOcean’s Frankfurt facility.

The problem I have is that is around 400ms packet roundtrip from Singapore, and the person I was hoping to bring in is located in Sydney, Australia, even further from Frankfurt!

Once I add the transit times, there is no way we could have conversation.

Do you plan to add additional servers in other locations?

Can we pay you to do that?

We have a DigitalOcean facility here in Singapore where I have a couple of hosts. That facility is 2ms from my desk, not 400ms.

(Are you still testing on iOS? I would love to have a look …)

@wibbly: Thank you for your detailed feedback. The server in Frankfurt is intended only as the switchboard. If the data needs to be relayed, it is supposed to hand this off to Twillio which operates thousands of servers. I’ll check with engineering if that is already working. I’ve sent you an invite for the iOS app.

Hi @wibbly, I’m working on mimoCall and am happy to assist you with your problems.

As a matter of fact, I was in Singapore for one semester on a student exchange programme in 2014, so I feel for you when it comes to network latency to european/american servers.

As Oliver already said, the server in Frankfurt is only for initializing the connection between the two peers. In the best case, the clients are able to connect to each other peer-to-peer to give the best network latency possible. However, if one of the two routers blocks direct connections, the signal is relayed using one of Twillio’s globally distributed servers.

Can you please tell me what kind of connection information is displayed in the web client’s status overlay? (tell your guest to click on the dashboard icon on the top right). Are one or both connections displayed as “Relayed”?

Thanks for prompt responses guys!

Give me a day or two to get my colleague back online and testing. He’s a very reluctant guinea pig.

I’ll get back on this thread as soon as I have more answers.

It looks like I’m going to be delayed for a while on this. I need to send a new camera to Australia, as the current one has failed.

I have another question … is there any way for me to get the audio out of mimoCall to send to my audio mixing desk. Can I output the raw audio coming from the call?

@wibbly Sorry to hear about the camera problems. I hope you get those resolved soon.

Currently, mimoLive has two audio outputs: Program and Monitor.

Program contains all audio and is sent out for the live stream, the SDI Playout and an audio output of your choice. You can set that up using the little cogwheel to the right of the Program meters below the program video window.

Monitor can be used for the operator and/or the moderator. You can configure the Monitor Mix to not contain the local audio so you don’t hear yourself in a mimoCall using the cogwheel next to the Monitor meters.

mimoCall clients get a Program out minus their own audio, so they hear everything except themselves.

If you want to tap into the incoming mimoCall audio, you could do it through the Monitor output. However, that may limit your use of it for other things.

Great audio detail. Really helpful. Thank you Oliver.

A terrific thread on configuring audio. I regularly use mimoCall. It’s terrific, except for the echo on the remote call. Being able to mute my input at the MimoLive end is brilliant, but what can be done about the echo for the folks I am interviewing?

Hi @Dsal22,

do you experience echos when your guests are wearing headphones or are they using their computer speakers? Echos should be reduced drastically when a headset is used.

Both. I thought about this again to try to pin it down, and it’s actually the latency on their own voice on the broadcast. When you hear the delay on your own voice the tendency is to hesitate then start, hesitate, start, hesitate and prevent the conversation flowing. Muting their mic eliminates feedback but here it isn’t their mic but the latency on their voice on the broadcast feed causing the problem. It’s like we need to mute their voice on the audio they hear on their mimocall or have the option to do that after they have established that their audio is working. Does this make sense and is something like that possible?