BUG: VideoSwitcher + mimocall + control surface

I created a Video Switcher layer, with 6 mimocalls instead of the placeholder.
I also prepared the 6 mimocalls “invite link” but I want to prepare the broadcast in advance by assigning buttons to the switcher.
When I go to the web Control Surface, I can’t assign the ACTION to all of the sources of the Video Switcher layer.
I am able to see just an active mimocall, but not the others.
If I put the placeholders it works, and I can assign “dissolve 1” and so on… but then how I can be sure that when I replace the placeholders with the mimocalls is it going to work as programmed?
it seems like a bug, unless I’m missing something.
I’m on 5.9b1

I tried to assign 3 placeholders iin the videoswitcher layer.
then in the web control surface I assigned “dissolve 1” to placeholder A, “dissolve 2” to placeholder B, and “dissolve 3” to placeholder C.
it works as expected.
But if I then replace the 3 placeholders with the 3 already made mimocalls sources (which are inactive), the dissolve is ignored. The cut works as default.
If the mimocall source is active (with a remote guest connected) then it works.

So I’m not able to program in advance the buttons and the layers.
Is this a bug just for the Switcher layer? if I’m going to use 6 separate Placers will it work fine?

@fermento I’m sorry for the troubles. I ran into the same thing just last week.

It is not a bug but it is very inconvenient. When there is no video from a source, the Switcher layer treats it as if it were not assigned. The solution for this will be that the mimoCall Source sends a video even if nobody is connected. This will be added in one of the next betas.

Meanwhile, you can simply assign the same source (your webcam or the one mimoCall that you have connected) as a placeholder to the switcher to set up the remote control surface. Once you’ve done this, you can assign the sources to the switcher properly.