Big problem in Sonoma 14.0

I don’t think these are mimoLive problems (which is why I’m posting here rather than sending a bug report), it seems to be Sonoma itself.

I’ve run into a problem when sending video from one app to another app (which is pretty key for all of us). For example:

  • mimoLive → Zoom (via the virtual camera)
  • NDI Test Patterns → Teams (via NDI Virtual Input)
  • etc.

Sonoma seems to be activating the video effects (both portrait AND studio light) on the ‘camera’ going into the destination app. You CAN NOT turn the behaviour off, when you click on the camera icon in the menu bar, the options to turn off the video effects in the destination app are not there.

This is disastrous when sending anything that doesn’t have a face in it - for example: slides, or if there is other stuff near a face that you care about. Everything turns into an out of focus mess.

Furthermore - it is intermittent. Sometimes the effects are active, some times they are not. You can run a test or start an event and everything may seem fine at first (ask me how I know :frowning: ), but then the effects will kick and you lose all the detail. Either way the options to enable/disable the video effects never show up in the camera menu (in the tab for the destination app).

Steps to reproduce with mimoLive and Zoom:

  1. Start mimoLive, new default document
  2. in the green camera menu (in the menu bar), make sure the video effects are switched off
  3. Add Virtual Camera to the output destinations
  4. Start Zoom, start a personal meeting
  5. Select the mimoLive virtual camera and enable it, you will probably see the blur effect
  6. open the green camera menu, click on the Zoom tab, note that there are no controls for the video effects.

Steps to reproduce without mimoLive (which is why I don’t think mimoLive or is at fault here):

  1. Start NDI Test patters and NDI Virtual Input
  2. Set the virtual input to use the NDI feed from test patterns
  3. Start Teams (or whatever), and start a ‘meet now’
  4. Change the camera setting to use the NDI Camera and enable it, you will probably see the blur effect
  5. open the green camera menu, click on the Microsoft Teams tab, note that there are no controls for the video effects.

It’s possible that this might be a Sonoma compatibility bug in both Zoom (v5.16.2) and Teams (v1.6.00.26463), but I now think this is probably a bug in Sonoma’s handling of virtual cameras. I tested this by directly connecting a USB webcam and having it as a source in mimoLive - the effects controls for the webcam showed up (and were honoured) in the green camera menu). That said, I’m no expert in how virtual cameras are handled, so that conclusion may be wrong.

Dammit… and it all seemed to be going so well.

Up on this: I’m starting to doubt myself a little, I now can’t reproduce it in Teams. Maybe it is Zoom after all?

For those curious, see the attached screen cap (all showing the same live NDI output from mimoLive): Clockwise from upper left: Teams, mimoLive performance monitor, green camera menu, Zoom, NDI Video Monitor.

Hi @Keith_4914 Thanks for reporting this! It seems indeed that there is something going on with the Virtual Camera plugins. In Somona 14.1 Developer Beta 2, the old DAL based virtual cameras do no longer work. I reached out to Apple about this but haven’t heard back.

We’re close to releasing a new Virtual Camera based on the Camera Extension stuff, so maybe that will fix this.