All my Storyboard thumbnails are displayed as blank slides or don't display the current select slide

        <div class="EmbeddedContent"><strong>All my Storyboard thumbnails are displayed as blank slides or don't display the current select slide. Is there a way to fix this?</strong>
           <p>If your storyboard thumbnails display wrong slides or simply displays blank slides click on </p>
           <p><a href="">Read the full story here</a></p>
           <div class="ClearFix"></div>

I created a slideshow, saved it, and then quit the program. I came back later to work on it again, and now all of the storyboard thumbnails are blank. I do not have the option of “Rebuild Storyboard Thumbnails” under my slideshow menu. I do have a “Rebuild Thumbnails” under my File menu. I tried that and nothing changed. There is also the option for “Locate Missing Files” but that is greyed out for me. The images do still show as being used in the images view (they all still have the green 1), but they do not show in the storyboard. I am using the free demo version (version 4.2.3) to see if this software will work for me or not before I buy it. I do not want to spend the $99 for this software if it is unusable to me for this issue (or any other reason). Please advise, thanks!

@msalmi78: We had a bug about loosing the connection to some files. This should be fixed in FotoMagico 4.2.3. However the document you have will stay corrupted. You may be albe to save some work if your are going to put the images again from the image browsr into your story board with dropping them to the existing slides. The slides will get updated without loosing the timing or visual settings. Sorry for that!

I have just experienced the same problem. I had a completed slideshow that I had already exported to youtube and it worked fine. In the meantime, I updated to the latest version 4.2.3. I just opened the same slideshow to export it to a DVD. The export failed and gave me an error message. I then noticed over 80% of my images are blank showing as missing. Rebuild thumbnails has not worked. The images are there and shown as being used. I began dropping the missing images on to the existing slides - it added them all at a zoom of 0%, so I had to fix that on every slide. Then, when I got about half way through dropping images on existing slides this stopped working. The missing slide message goes but there is just a blank screen and the zoom field shows as NaN. Changing this to 100% does not change anything. Since purchasing this version of FotoMagico I have tried to create 2 slideshows. Both appear to have ended up corrupted. I have emailed support both times and am waiting for a response. I hope to get one soon.