4.5 sound with flicking noise

On latest version 4.5 after a while I found the the sound from my usb input started to have some subtle “flick” sound. It is like static sound and it is especially apparent when in silent environment. I turned off the sound from the source to show you how it sounds like. It does not happen in 4.4.1.

I use Focusrite Scarlette 2i2 USB as my only sound source, and i attached a picture to show my setting.

Please help when you get a chance. Thanks.


@“Jason Lee” Thank you for reporting your issue.

Unfortunately I don’t have a Scarlett audio interface handy. I tried to reproduce the issue with another USB audio interface but was not able to find anything as of yet.

A few questions:

  • Do the audio artifacts change in quantity and/or quality when the input is not “silence”? Can you provide an example?

  • Do the audio artifacts change in quantity and/or quality when you change the device input sample rate?

  • Do you experience the issue only in mimoLive or does it occur -at the same time- in other applications using the same audio device?

  • Is there other software running on your machine that could potentially compete with mimoLive for the Scarlett?

  • Does the issue occur in a fresh mimoLive document with only the Audio Source containing the Scarlett as input device?

  • Are you running mimoLive on a smaller audio buffer size than the default 512 samples? If so, try setting it back to the default. Go to Preferences > General > Audio Buffer Size.

  • If you have other hardware available, do you experience the issue with other (USB) audio devices?

If all of this does not bring any enlightenment to you I would like to ask you to record further tests with a blank document:

  • First, let’s eliminate the internal audio engine processing as culprit and run a test with a signal like a simple sine wave at a fixed frequency, e.g. 1k Hz, as a media source in a placer layer.

  • Then set up an audio source and send a test signal as input through the Scarlett. This should help us to better understand what’s happening to the input signal.

On a more practical note regarding the audio setup in your screenshot, are you aware that the Audio Mix Panel lets you solo a layer instead of muting all others?

@“Jason Lee” Also of interest: What exactly does “after a while” mean? Does the audio degrade after a few seconds, after some minutes?

Thanks Beni for your quick reply, to answer your questions:

  • Yes it is the same with some ambience sound and I attached mimoLive4.5_PianoSample in the same link for your reference.
  • I never tried to change the device input sample rate. I use 48kHz.
  • This problem appears only in mimoLive, and that is the only application running when I experience this
  • After a while means about 2 minutes. It seems when I started to have sound it will start to have the artifact left over towards the silence part of the song.

Thanks for your all suggested configuration changes. I will try it out later and find out a minimal reproducible case.

P.S. Another problem I experienced was the delay in the all the outputs I put into my configurations. I have 2 outputs, HDMI out and Scarlett USB out and the sound of each output gets delay and out of sync over time. It seems to affect live output only and not the recording (may be the recorded video was also delayed so they are still in sync). I am not talking about the usual delay of video to live which I understand it is natural with digital video. The delay is sound only and get worst over time.

The workaround is to stop and start the audio output, then it will be in sync again. It is per output so let say you restarted the USB out, HDMI out is out of sync. So I have to start and stop the audio once in a while.

@“Jason Lee” Thank you for the additional audio sample, it’s helpful in that the audio artifacts can be seen more clearly in the waveform.

Regarding the other problem you describe, what you experience can be explained by the File Recording output destination and the Audio Aux output destination using different processes to acquire and write audio data.

Can you tell how much audio delay is built up over how much time? A lip sync test video might help in determining this.

Could you please run mimoLive in Debug Mode, reproduce both issues and send me the log? You can send it as a private message if you prefer.

Also let me know what Mac you’re running mimoLive on.

Hi Beni,

Ran in debug mode and captured the debug log in mimoLive4.5_Audio_debug_Log.txt. A lot of errors:

error 22:16:56.919040 -0800 mimoLive CGAffineTransformInvert: singular matrix.
default 22:16:57.304934 -0800 mimoLive HALC_ProxyIOContext.cpp:1068:IOWorkLoop: HALC_ProxyIOContext::IOWorkLoop: skipping cycle due to overload

Also I tried to run with just the audio layer. After 5 minutes and not able to reproduce. So it must be some other layers causing this, even i muted all of them. Captures another debug log mimoLive4.5_noArtifact_Log.txt

Edit: after some more testing it does show the artifacts even with 1 layer with the usb audio. It is apparent when you suddenly stop an upbeat audio. Captured another log mimoLive4.5_SuddenStopArtifact_Log.txt

But as you can tell it is tedious to isolate the actual cause of it. So will need some time.

@“Jason Lee” From the logs I can tell that audio input from a Core Audio device -most likely the Scarlett- is a tad too slow which -I guess- accumulates over time until mimoLive’s audio engine eventually fills the lag up with silence which becomes audible as click noises. This behavior could be an indicator that the system or one of its subsystems like I/O is being pushed towards its limits.

Unfortunately I don’t see mimoLive4.5_SuddenStopArtifact_Log.txt. Were there other documents open in mimoLive at the same time?

Could you please let me know what Mac you’re running mimoLive on?

The machine is Mac Pro late-2013 quad-core 3.7GHz with dual AMD FirePro D300 graphics.

So with 4.5 does it need more system resources? I don’t remember I was facing audio performance problem before. For example with 4.4.1 it has no problem at all.

I also added back mimoLive4.5_SuddenStopArtifact_Log.txt.

@“Jason Lee” The way how audio input is handled by mimoLive changed quite a bit between 4.4.1 and 4.5, mainly to fix a bug with the input level metering. I will see if there’s another bug slumbering in the new implementation.

It would help if you could tell me what macOS version you’re running on.

Also could you please confirm that mimoLive4.5_noArtifact_Log.txt and mimoLive4.5_noArtifact_Log.txt are from mimoLive sessions where only one document was open in mimoLive and only one source and one layer and the default audio output destination were present in that document and no other app was running? That is, the one mimoLive audio input process was the only process causing (notable) user-initiated CPU load?

any updates on this one? I hear a slight popping on mine too and I have a Scarlett 2i2 as well. Thanks.

I just tried 4.6 and I can still hear the flicking noice on my scarlett 2i2. I found the 4.3.1 is the last version that is stable and does not have this problem. I think this might be device specific. I have yet to try other usb audio adaptor.

For the record I am using macOS Mojave 10.14.2 and the log I generated was only 1 layer and the audio source is solo on Scalett 2i2 USB only. Also Mimolive was the only app running.

I’ll share a couple links from my stream the other day. This was a brand new template from scratch & I changed to 44.1 sampling rate. It seems the most noticeable here the first minute or so is this what you’ve been hearing? https://www.youtube.com/watch?v=EbWSh9gIesE

I don’t notice it so much, if any the second part: https://www.youtube.com/watch?v=wCbMDvAdjUQ

@“Jason Lee” @kmac1036 I’m sorry about those issues. It has recently come to our attention that there is an issue with USB devices on the newer Mac models with T2 chip. There are a couple of workarounds like using a Thunderbolt 3 dock or temporarily disabling the “timed” service on Mac OS. More info: https://www.reddit.com/r/apple/comments/anvufc/psa_2018_macs_with_t2_chip_unusable_with_external/

Apple is aware of the issue and will hopefully provide a fix soon.

@“Oliver (Boinx)” I will look into that, however, none of the macs mentioned here are new enough for the T2 chip or to have TB3… I will see how tonight goes and report back.

@“Oliver (Boinx)” @kmac1036 Yes, I am experiencing what looks like it could be a related problem (audio drift) on a Touchbar MacBook Pro from the T1 generation. I’ve been emailing support about it.

The workaround I’m using is to insert Loopback (the application from Rogue Amoeba) in the chain between my audio device and mimoLive. I created a virtual device and linked up the audio hardware as the only input channels.

With this in place, my audio drift problems have disappeared.

Worth a try if you have access to Loopback.

@“Oliver (Boinx)” I was using Mac Pro (late 2013) and it does not have the T2 chip, so that T2 chip issue does not apply. Also I use another USB audio device Behringer Xenyx 502, it also has the same issue. So I have to use the recording directly from the mixer and fix it in post, which is tedious.

Can you publish a list of USB audio device that can be used with Mimolive 4.5+ without flicking noise? Thanks.

@“Jason Lee” I’m sorry to hear that the issues continue for you. Thank you for your patience.

The way this is programmed, we do not support any specific devices. macOS provides an abstraction to the different devices from different vendors, so, in theory, either all of them should work or none of them. I use a Zoom H5 and do not experience these flicking noises, so it is difficult for us to track down this issue.

You can try to turn off the timed process as is mentioned in the workaround for the T2 issue and see if that works.

I wonder if my issue is related? I already submitted to tech support, but maybe a user can shed additional light on this? I am running a Macbook Pro 13" w/Touchbar. 2018 version. I’m running MacOS 14.14.4.

While we were broadcasting, the audio started to buzz, like it was being pixelated, voices and sound were distorted as if the sample rate went waaay down. The audio coming out of the program mix, however, appears clean. It was only my local monitoring mix (Audio Mix 4) that was buzzing. Turning the mix off then back on seemed to temporarily correct the problem. It would last for 5-10 minutes, then start degrading again. The Interface is an Apogee Element 24. The interface is a Thunderbolt 2, connected to the Macbook with an Apple Thunderbolt 2 to Thunderbolt 3 adapter. The interface works fine in other audio apps so it is not a hardware issue. My internet is gigabit, coming over a direct Ethernet connection. Usually I turn Wifi off when I broadcast.

Anyone have any thoughts as to what might be going on?

wanted to see where people are with this one and if 10.14.5 finally fixed it?