Unable to access file when sharing with iDVD

I made a slideshow which I shared with iDVD. I decided to revise it. I renamed the file of photos and tried to share with iDVD. What I’m getting is an error message saying that “A file or directory could not be found”. What did I do wrong?

What are the steps of your workflow and at which state are you getting this error message?

Hi,
Thanks for your prompt reply!
I set up the slideshow with transitions and music choices. I set up an iDVD project by the same name. I then tried to share the PhotoPresenter show with iDVD. At that point I got the error message. It has worked for everything else I’ve tried. The only difference with this project is that I had already completed a project and burned a DVD with these photos. I decided I didn’t like a part of it and so revised it. So really, I’m re burning a lot of the same photos, same music and transition choices. I’ve tried re naming the slideshow in iPhoto and iDVD, but no luck. I must have done something, but can’t figure it out.

Did you create a new iDVD-Project? PhotoPresenter isn’t able to update an project once it has been transferred to iDVD. You have to create a new one and do the iDVD export from PhotoPresenter again.

Yes. I even trashed the old slideshow and opened a new project. Arrrgh!

I think the problem might be that iDVD can’t find the exported movie by PhotoPresenter. So I am looking for the reason here. Do you have the apps on different hard drives?

Only on our back up external hard drive.

What is the duration of your slideshow?

The music is 4 min. 51 sec. So, slightly longer than that.

Can you please try to remove the PhotoPresenter Preferences?

-Make sure PhotoPresenter is NOT running

  • Select “Go” in Finder’s Menu while holding down the “alt” key. You will get a additional menu entry called “Library”. Select it, a new Finder window with the contents of the “Library” folder will appear.
  • Look out for the “Preferences” folder and select it.
  • search for all “com.boinx.PhotoPresenter” files and move them to your Desktop to keep them in case something went wrong.
  • Start PhotoPresenter and try your export workflow again.

Hopefully this will solve the issue. If not, and you think you are missing some preferences in PhotoPresenter, just bring those files back in place.

Thanks. I will try it.

Finally had a chance to try this. There are 4 listings in the library. 2 are com.photopresenter.mac.plist and 2 are com.photopresenter.mac.plist.lockfile. They alternate. Which one do I choose?

Move all files thats indicates “photopresenter” out of the Preference folder to the desktop. You are pretty safe to do so because it’s like to reset an application to factory defaults. By definition: If a preference file is missing for an application it is its responsibility to recreate the file if the user does change the preferences of the application.

I tried it. It didn’t work. Same error message. Hmmmm.

As a workaround can you try to export the slideshow with the “QuickTime Movie” option and move the exported movie file manually into your iDVD project? Does this work for you?

I’ll try it. Thank you!

Hi, Unable to work on this for quite a while. Summertime! I tried what you suggested but it did not work. Again, an error message. This time: An invalid filename or volume name was encountered. Would it help to trash and then re install the program?

Trashing the app don’t help, you have to trash the preferences if you want to reset it to factory defaults, but I think this won’t work in this case. What is the name you are using to export to? Where do you try to export to? Are you using foreign characters in the folder names?

I tried exporting to both iDVD and QuickTime movie in the drop down. No foreign characters. I haven’t yet got the skills to try to figure out anything else. Am I doing something wrong?

Which MacOS-X version you are on? Which version of PhotoPresenter are you using?