Trying to use iStopmotion with Nikon L18

Hello,

I’m sure I’m skipping a step. The demo works fine with iSight, but I’d prefer to work with a handheld camera.

I’m trying to use a Nikon Coolpix L18 which is on your list of approved cameras. In the demo, I switch the source from built in iSight to L18. (I searched the camera for a PTP mode on the menu but didn’t see an option to switch it to PTP mode). In the program, I get the black and white screen that says, “No live preview for selected device. Still Camera images sources like the selected input device, L18, are not capable of providing a live video preview. You need to manually update the preview by pressing the preview button in the transport area.” So I press capture still camera image preview, the program & my camera goes off, “capturing one frame, recording” shows up on the screen, then I get a message saying “Capturing an image failed because the operation times out. Please check your device and it’s connection to your Mac. If this doesn’t help, try with a different one.” But the images show up on the camera itself. When I try to import still images from the camera (movie>import images>still camera) through the program, nothing shows up in the window. I’m on an iMac, version 10.6.7. I’m using istopmotion Home 2.5 demo.

Thank you,
Adria

I’m having the same issue with the Nikon Coolpix L22 on my MacBook 10.6.7. Any help is appreciated!

Exactly the same for me, with a Nikon Coolpix S3100, iMac running 10.6.7 with iStopmotion demo.

Please make sure the camera is set to JPG recording and manual focus to avoid long loading times (as many settings to “manual” as possible is recommend, also “PTP-mode” if available). It is also advised that there is a certain amount of space available on the memory card (an empty one is even better). Please also try the latest version of iStopMotion. For now we don’t recommend to upgrade to 10.6.8 again due to technical reasons.

We released iStopMotion version 2.8 specifically to work around problems with still cameras on Mac OS X v10.6.7 as Apple made major changes in 10.6.6 and 10.6.7. If you are still running 10.6.7 please update to iStopMotion 2.8. Everything should work fine there.

However, if you have updated to Mac OS X v10.6.8 in the meantime we are all out of luck. Apple once again massively changed how still cameras are addressed by apps and so we are back to the drawing board on that. We will release a new beta version as soon as we found a way to make it work again and announce it both on the forum and our beta page.

Sorry for the hassle!

While not a final solution, we have managed to get still camera support working again for 10.6.8 and OS X Lion. Right now there are 2 caveats:

  1. make sure your memory card is initially empty
  2. set your camera to shot only RAW or JPG but not both.
    Get details and software here: http://boinx.com/istopmotion/beta/

Feel free to report your findings!

I am having the exact same problem with Nikon L22. the camera will take a picture, but with the same timeout error. This is with version 2.7

Macbook Pro 10.6.6

I tried upgrading to 2.8.1 and get the same timeout message.

I used an empty SD card and am not sure if I can set JPG or RAW on camera.

Interesting. with 2.7, if I tried another picture, the camera would not take another picture. Would just give the timeout. with 2.8.1, the camera will happily take pictures every time, timing out every time too though.

Other interesting fact. If I try to import the pictures movie/import images/still camera, the pictures that I took using the preview button do not show up unless I disconnect the camera and then reconnect it. I tried closing iStopMotion and restarting it, but that didn’t work. I had to disconnect/reconnect the camera.

Have you tried the 2.8.2 beta? The 2.8.1 won’t work since it does not contain the first fixes for the camera tethering…

Is there any reason you stay on 10.6.6?

Thanks. I just tried the beta. Although it behaves slightly differently than before ( a computer-generated shutter sound when clicking preview, before the actual picture is taken), it gives the same timeout error.

I will upgrade to 10.6.8 to see if that helps.

Unfortunately, that did not work either :frowning:

I tried deleting all the images from the SD card and memory and that didn’t help.

I think it may a mac issue, but I’m not sure where to start.

Here’s what I did.

  1. Empty out all pictures from SD card and memory
  2. Connected camera to MBP. Camera was on
  3. Opened beta 2.8.2 and tried to do a preview. Got timeout error
  4. Quit iSM
  5. Open Nikon transfer utility. Picture (from preview) is not there. There are no pictures at all
  6. Turn camera off leaving tethered
  7. Turn camera back on
  8. Preview picture is now visible in Nikon transfer utility

So it seems it is not just your app that can’t see the pictures that are taken while tethered.

Hope this helps to find a solution! My son really wants it to work :slight_smile:

Sorry if I sound annoyed, but I have just wasted 2 hours of my life (and, worse, my son’s patience) finding this out. I bought this program from the Apple App store, only to find that it doesn’t work with a playstation camera (not even with Macam), it doesn’t work with a Sony compact camera and it doesn’t work with a Nikon D90. You’ll perhaps forgive me asking when you might make this work so that it is fit for sale? I for one will be asking for a refund for this inadequate support.

Are there any official drivers for the PlayStation camera on Mac?

The D90 should be fine but again, if Apple changes major routines in the frameworks without telling anything in advance, this causes difficulties we could not expect. We had put a lot of effort and manpower into fixing this the last time, and now it has happenend again.
So again we are working on the solution very hard, I think you can imagine together with the upcoming Lion release how busy our dev guys are at the moment… We’re really doing our best.

Well, I just ordered the Ipevo camera. Since it’s “the best for iStopMotion”, this one should work!

I was also having trouble with istopmotion with the nikon coolpix s8100 but can report success with the beta release 2.8.2 beta 1. I’m on mac osx 10.6.8 running on a mini.

My Nikon D3000 worked with 2.7, but gives the timeout on 2.8

Have you tried the beta?

http://boinx.com/istopmotion/beta/

iStopMotion 2.8.2 (final) has just been released. It should work fine on OS X ranging from 10.5.8 to 10.7, including 10.6.8.

My only hesitation is that the IPVEO has only a 2megapixel camera. Is anyone using another webcam successfully?

I’m running Mac OSX 10.6.8, have a Nikon Coolpix S3100 (which on the test still camera feature states can capture images). I tried it in 2.7 and got the timeout message, then upgraded to 2.8.3 and am still getting the timeout message. >:( grrr. I’ve cleared the memory, put all the settings I can to manual, (no option on menu to switch to PTP) … why am I still getting this error!? So frustrating.

Hello, I have a Nikon S3000 which also times out. Have upgraded to 2.8.3 and Lion. Can you please fix, this is killing me!