Save let the program hang

When i save by hand: File-Save the program hang.

I get that too. On two separate files. I have to Force-Quit.

More info: I am using FotoMagico 5, version Also this only started after the last update a couple days ago.

Same here, although mine also hangs on Auto-Save. No response in 24 hrs. from my tech support contact. Had to revert to the v.5 Beta to keep working.

Heard from tech support. They first had me use AppCleaner to make sure I had totally deleted all the support files. Then a restart, then download a fresh copy of FM. But it didn’t work, and mine still will not Save, either manually or auto, to my boot drive or an external RAID. Reverting again to the beta, which is flawless, until I hear back.

I have the same problem. I’m using Pro 5.0.2 on El Capitan OS. Using save or save as causes hang. I am able to recover after force quit and relaunch Fotomagico.

Same here, cannot work that way, the tool is useless, and I’ve paid for the PRO version
Please fix.

Same Problem (FotoMagico Pro 5.0.2, El Capitan 10.11.4)!

Unfortunately, I’m noticing the same problem in 5.0.2 – but only sometimes. I can make some edits and press Command-S for a Save. Make a few more edits, save again. But eventually during a save it will hang – spinning beach ball and rotating petals. Have to do a Force Quit, then a restore on the next start-up :frowning:

Same issue for me. Happens using menu choice, keyboard shortcut, and auto save by the application. Program is useless until this is fixed. Not at all happy.

I have experienced the same problem, the program hangs every time I save.

It does save the file though. After restarting I discovered that the session was saved correctly.

Very annoying.

Same Problem (FotoMagico Pro 5.0.2, El Capitan 10.11.3)!
I had no problems with the beta Software.

Same problem with new Fotomagico Pro 5.0.2

As a workaround and tip from the support, we should use ⌥ ⌘S (ALT CMD S)

I submitted this problem to Boinx tech support and received the following response (in case it helps someone else out):

This is a very strange issue, I’m sorry for the inconveniences you’re facing. To make sure that this is not caused by the corruption of the application files, please try fully reinstalling FotoMagico. This can be easily done with AppCleaner that you can download from the link below:

Simply start AppCleaner and drag into it any FotoMagico icon you’ll be able to find in your Applications and Downloads folders, then choose to remove it with all of the leftovers. Once it’s done, please restart your Mac, then download and install FotoMagico one more time with the following link (unpack it and drag FotoMagico into your Applications folder):

This solved my problem for about three saves of the file I was using before the problem began again. So no solution yet for me.


I’m having the same problem - Fotomagico 5.0.2 on El Capitan 10.11.4. Every time I start the program, it gives an error message “Cannot locate media files” When I go through the routine of locating files it will start normally but very shortly it will hang, and I get the spinning wheel. It was running fine for about 10 days after I installed the software until this morning - and there have been no software or OS updates.

I’ve been a longtime user of FotoMagico. As posted above, I have the same problem. I know it’s inconvenient, but as tubrat noted (and I can concur), even though the app is hanging during the save, when I do a “Recover” all of my changes HAD BEEN SAVED – but it is inconvenient.

I’m sure the guys at Boinx are now aware of the problem and looking for a fix. They have always come through. Give 'em some time…

The hang seems to occur while creating thumbnails during a save.

Yes, I know they’ll fix this, and in the meantime I’m fine using the Beta. Still, when I cannot really use the software (sorry, force-quitting every time I save is NOT what I would call a workaround, and may eventually corrupt the file) it’s a bit annoying to get yet another email today touting it being featured on the App Store and that they’re showing it off at NAB next week. Hope they can fit in some debugging with all that going on :slight_smile:

After a few discussions with tech support, there is a workaround: Disable auto saving in preferences, general. When you want to save the project you are working on, select file from the menu, and while pressing the option key, select full save. It’s been working for me in version 5.0.2.