Running latest Version 4.3 with a few niggles.

First to say version 4.3 is much improved! I do though have a few problems sighted:

  1. There is no more the “save as” choice under “file”. Is this intentional in version 4.3?
  2. Notice all music dropped into Fotomagico is around 1/2 the volume of the same sound clip played on the Mac. (I do realize the volume can be increased within Fotomagico)
  3. Whenever ‘changing’ an already inserted text on a slide and then closing Fotomagio it won’t save the change, but if I re-open the Presentation the original text is still there but if I click on the text then the newer changed text replaces it, but again won’t save when closing the presentation with the red bullet. The only way for the text to be updated and saved is to delete the text box completely and then re-write it.
    Lieber Fotomagico, vielen dank für euere Hilfe

I can confirm #3 above, although I didn’t have to re-write the text.

When I made a text edit and clicked “Save”, then closed the file and re-opened it, the old text is still there. If I double-click on the text block the NEW text magically pops up. If I click “Save” again and close the file and re-open it, again the old text is still there, but a double-click magically brings up the NEW text.

If I do a “Save as…” however, and use the same file name, it asks if I want to replace the old file with the new one. If I answer “Replace”, close the file, then re-open it, the NEW text appears.

This needs to be looked at.

Stantastic, Thanks for your response! You have the same issue as I have found. Concerning though “save as” ,if I type "save as " in the help box it then arrows over and shows a “save as” under file but when closing help and returning to search for “save as” under file it isn’t there. Bill

We fixed some bugs regarding the text editing in the upcoming version. Please be patience it will come soon.

The only way for the text to be updated and saved is to delete the text box completely and then re-write it.

My experience is that is caused by the thumbnail not updating to show the change. If I click on another photo and then come back to the one with changed text it updates and shows the correct text. This is much easier than what you’ve had to do. Does my “trick” work for you?

Hello jrhall, I finished my current presentation but I did have several times where I re-edited several texts under different photos at one time and then closed the program and none of the changes saved. I found only if I removed the text box and then re-entered it then it saved. In all honesty the latest version is working quite well with only a couple if these smaller problems but I am sure Fotomagico wants to improve on those too. Do you have under “file” only “save” or do you also have a “save as”? Thanks Bill

I tried jrhall’s suggestion but it didn’t seem to work – or maybe I misunderstood the process. I have both “Save” and “Save As…” on my menu, so I can choose either one. “Save” makes more sense after you make an edit, but it doesn’t seem to be working. I’ll click on “Save” but nothing really happens. If I choose on “Save As…” then choose the same file name, it asks if I want to update that version, which I choose to do – THEN it seems the text edit gets saved (along with other changes to the file).

As Achim has pointed out, they fixed some bugs for text editing, so perhaps this issue is resolved in the next release. I’ll wait and see for now…

Anyone know why the “save as” isn’t appearing under "file. What is interesting though is that if I type “save as” under help it arrows over and shows a “save as” under file but if I close the help column and click on file again there is no “save as” there. Bill

@Bill: I tested it with 10.8 and it looks like this is a wrong behavior in MacOS-X: If you switched on “autosave” in FotoMagico preferences the “Save As…” gets changed to “Duplicate”. however the Help menu search is still able to show the “Save As…” menu item. Sorry about the confusion! If you want to save you document with different name, please use the “Duplicate” menu item.

I was going to comment on how much better 4.3 was and now there is 4.3.1 with an impressive list of fixes! Thanks…we’ll check them out!

I did my first significant (28 minutes) slide-show in 4.3 and really had fun masking and layering… Going to do a demo at the Apple Corps of Dallas SIG next month… I will say that I ran into the old (?) missing file problem once—very scary—throwing away preferences fixed it. However, don’t understand—and it scares me—with FM has to “resave” seemingly every file for no obvious reason…

Hallo Lieber Achim, Vielen dank für deine Hilfe. Alles ist jetzt klar! Bill

@raymackt: Old fms projects could have the “missing media” already from the previous version of FotoMagico. Those missing media files can’t be resolved by FotoMagico 4.3. However new missing media files shouldn’t happen anymore. If this is the case, we highly appreciate any further examination of this issue!

Why and when does FotoMagico need to resave the complete project? FotoMagico is tracking all the media files that are in your project. Once you add a new media file it only makes a note, where this new media file is located in the system. For performance reasons it doesn’t copy this file immediately. Now the project file is “dirty” and has to saved completely again: A new project file is created, all the media files are copied and only after a successful creation of the new project file, the old one gets trashed. This way FotoMagico can’t destroy the document structure if it crashes in the middle of a save process. On the other hand if you opened up a document and only made some changes in a slide position or adjusted timing, FotoMagico don’t need to resave the complete document: It just saves the project structure the same way, but this is much faster, because we can do it inside the project file itself and don’t need to touch the media files. Does this make sense?