New (trial) user; not off to a good start

Hey folks, this looks amazingly powerful but MAN I’m not off to a good start…

mimoLive 5.7 on Mac mini on macOS 10.15.5
mimoCaller on iPad iOS 13.4.1
mimoCaller on iPhone on iOS 13.5.1
mimoCaller on MacBook Pro on macOS 10.15.6 (beta) and Chrome 83.0.4103.61

  1. I created a new project using the “call-in show” template

  2. Immediately tried connecting to one of the mimoCaller (A) URLs from an iPad. In Chrome, the page just loads solid grey. No camera requests, no interface, just a wall of grey. I tried Safari, and that connects. At first, I did not see the Program from mimoLive on the iPad, but after a refresh it came up. But more importantly, on the Mac running mimoLive, it shows that the “partner” is connected, and I see the audio coming through, but the camera does not show up — even though on the iPad in Safari, I do see its own camera in the corner.

  3. I tried to connect mimoCaller B on an iPhone, got the same thing re: Chrome vs Safari, and got basically the same experience — audio comes through, video does not. Further, the UI on the iPhone is completely overlapping itself and essentially unusable. Gave up.

  4. I tried connecting mimoCaller B from a MacBook Pro. In Safari, the page keeps reloading. I tried Chrome, and finally the camera from that mimoCaller B Mac is coming through to mimoLive, so that’s good. I saw the mimoLive program on the mimoCaller B Mac initially, but then it disappeared. Still saw that Mac’s own webcam in the corner, and the mimoCall UI, but the Program disappeared. Reloading the page restored it. So for the moment, mimoCaller B Mac appears to be OK.

  5. Back to the iPad, I decided to try the app. I downloaded Reporter, refreshed and loaded the app. It prompted me to join the call; I accepted that, and I’m seeing myself (iPad webcam) full screen, with the Program in a tiny preview icon in the corner (and that took maybe a minute to show up; I was about to write that I didn’t see the Program at all). The audio and video is finally coming through to the mimoLive though. I see that you can add titles and such, so perhaps this is meant as a broadcast tool more than a “join the call” tool. So that means what I really need to be using is the browser (which is what I want to use to make it easier on guests), but it has all the problems noted above.

At this point, the iPad or iPhone are unusable as call-in devices, but the Mac works, albeit initially problematically. The mimoLive Program has been stable on the mimoCaller B Mac for a while now, so hopefully that holds. Oops I take that back… the Program is gone again.

Using just computers to call in is fine, but I can’t have the Program randomly disappear on the remote caller’s computer. Any words of wisdom here?



Try the MimoCall Repoter app (download it from the appstore). This will def help you a lot. At least on my side.

Please note: I’ve experienced quite a lot you will have to connect twice before it actually works on the iPhone, so be aware of that. As long as the return screen is blue, there is no actual full connection from Reporter back to MimoLive.

Thanks KHIo. But with the Reporter app, I saw myself large and the program return in a tiny window. Can you reverse that? Because that doesn’t make it a good experience for the caller to be a part of a meeting/conference/show/ etc.

@joseph1 Sorry to hear this trouble!

Recently we learned that certain network conditions may cause problems with mimoCall. A special secure environment made trouble and they were able to fix it by tuning their network (please don’t ask for details thought). Do your guests or you with mimoLive happen to be in special network conditions?

Secondly: mimoLive Reporter was developed to be a “reporter in the field” app which means thant the reporter is more interested in its own camera view than in the remote one. Thats why there is currently no option to swap the images.

Hi @Achim_Boinx thanks for the response.

Since this is just a trial, and I’m trying to determine if I can recommend this to my client, this is just me testing on my own network. Meaning the mimolive app and the mimoCall were originating from the same network (different computers of course). There’s nothing special about my network. No custom firewall, no VPN, nothing I’d consider unusual.

I understand the reporter app is not meant for this use. Mimocall through a web browser should be the solution and is easiest on the often extremely non-technical guests calling in. We’ve been using StreamYard but that is very limited. I really, really want mimoLive to work!


Maybe this is the problem (also we don’t experience this in our own network when testing): When mimoLive is trying to connect to a mimoCaller then this happens via a relay server to exchange IP addresses so that both mimoCall partners can send their video data to another. Maybe this exchange don’t work out quite well just because both of your endpoints are in the same network? Please can you try to make a mimoCall to someone who is outside of your local network?

I was thinking the same thing. I tested this morning successfully using a cellular connection from a laptop. I’ll be doing further tests this afternoon.

These tests got pushed to Friday. Question for @Achim_Boinx — I need some assistance determining which license is appropriate for my client. Who can I reach out to privately to discuss?

I will contact you by email.