mimoLive changes Video Input setting on BlackMagic Mini Recorder

Launching mimolive changes the video input setting on one of my BlackMagic Mini Recorders from SDI to HDMI.

I run 2 BlackMagic Studio Cameras connected to BlackMagic Mini Recorders through SDI and into our Mac Pro with Thunderbolt. When I launch mimoLive I can watch the video input in the BlackMagic Desktop Video Setup software change from SDI to HDMI on camera 1 (camera 2 is unaffected). I can then change the settings back to SDI and the video signal is restored, but it is a hassle to have to launch that software and make that change every time I launch mimoLive.

To troubleshoot the issue I tried:
Swapping the 2 Mini Recorders, still the one connected to Camera 1 switched inputs.
Installed brand new Mini Recorder to Camera 1, same outcome.
Set Video Input setting in BlackMagic software, opened many different programs, restarted computer; video input setting did not change. As soon as I launch mimoLive they changed again.

mimoLive Version 2.5
BlackMagic Desktop Video Setup Version 10.8

@HedrickTech Basically, this is mimoLive trying to be helpful. The first time and every subsequent time you set any device property in a video or audio source, mimoLive saves your choice as a default for that particular device. This happens, so anytime you set that device up in a source again, the settings you used last are automatically restored.

The issue here seems to be that mimoLive cannot distinguish between the two Mini Recorder devices. Different Blackmagic Design device models identify themselves to the system in different ways. So, this could be an issue if the Mini Recorder does not provide a unique per-device-ID. We will have to look into that.

To circumvent issues like these, mimoLive provides an option to disable automatic device preferences altogether. The option can be found in the Preferences > Debug > General > Disable Magic Device Preferences. You will see the debug tab only if you opened the preferences while holding the option/alt key. The shortcut would be option + cmd + ‘,’ (comma).

Now, here’s the catch: This debug option currently does not work correctly. We will fix that with the next beta.

@HedrickTech The latest beta of mimoLive should fix the debug option mentioned in my previous post. If you still experience any issues regarding video device input settings, let us know.

Just an FYI in case you are using both cameras in mimoLive: You can always configure the Mini Recorder input settings in the device settings panel of the video source that uses a Mini Recorder device inside mimoLive. So, no need to switch back and forth with the BMD Desktop Video Utility. On the other hand, you probably know that already since otherwise mimoLive would never have stored any device-dependent settings for your Mini Recorders in the first place.

Thanks Beni! I adjusted the device settings in the panel and it has fixed my issue.