MimoCall ECHO! Since updating to 5.9

After updating the software, there is a such a bad echo for the client they can’t even stay on the call.

How do I stop the echo to the client on a Mac - Chrome?

Hi @GrumpyGuru I’m sorry about the issues with mimoCall.
In most cases with echos, the reason is that the microphone at one end of the connection is picking up the audio. Can you please check if the “Caller hears” popup menu in the mimoCall setting pane is set to “Program Mix (Mix minus)”?

If that is not the problem, try to turn on the echo cancellation feature in the client to see if that helps.

You can also try the beta version of the new mimoCall client by taking the URL for the invitation and changing the first part from https://call.mimo.live/ to https://call.mimo.live/beta/

Please let me know if that works.