Matrox MXO2 drivers not working

I’ve had a lot of trouble with my Matrox MXO2 Mini & drivers. This was paired with a Blackmagic Intensity Extreme, running BTV 1.8.4 & OS X10.6.8. Kept getting intermittent black video issues with the Blackmagic box. they have since sorted out their issues with the driver & it’s rock solid. Now I can’t upgrade past 10.7.4 & Matrox software version 2.5. All I get is black video now if I try to upgrade to the never versions of their driver. I noticed on 2.6+ the available options from the list all disappear (1080i59.96, 720P59.96 etc) & all I see are 2 options for “Matrox.” Neither of them work. Tried on 10.8.2 & the new BTV 1.9 beta & still no luck. Matrox also doesn’t give you the capture utility either. Tried using the box on QuickTime, it’s the same result. The driver also messes up the Blackmagic box too it’s sometime also not available.

The Matrox was hooked up via the ExpressCard while the Intensity Extreme was via Thunderbolt cable. I saw very early on when TB was new there were issues with the firmware when using both interfaces, it would cause issues, but I think this is no longer the case, correct? I’ve updated the firmware on the Mac when they are released (Early 2011 17" MBP).

Any thoughts? Anyone else using Matrox equipment? Thanks.

I’m using a MacBook Pro 17" with 10.8.2 and Matrox MXO2 Mini. Last year Matrox released 3.x drivers which I was unable to get to work at all. But they obviously are aware of the problem and a few weeks ago they released updated 2.x drivers that are compatible with 10.8.2 again.
Right now I’m using BoinxTV 1.9b9 with Matrox drivers 2.6.1. This combination works pretty well. Also BoinxTV 1.8.4 works together with the 2.6.1 drivers.

BoinxTV beta: http://boinx.com/boinxtv/beta/
Matrox drivers: http://www.matrox.com/video/de/support/downloads/

Max
Boinx Software Ltd.

If anyone else is having trouble with their matrox please see this thread: http://boinx.com/forum/#/discussion/3725/matrox-mxo2-drivers-not-working