Live Preview using 60D in iStopMotion 3.7 not working

I’m posting this thread because I’m frustrated that the Live Preview does not appear to work in v.3.7 which I just bought yesterday. I couldn’t find any specific settings for the camera, but after a bit of time in the forum, I removed the memory card, changed the capture settings to JPG (not RAW), made sure Canon EOS Utility was not running, etc.

Unfortunately (?) my solution was to download the previous version of the software here:
http://boinx.com/software/istopmotion/Boinx_iStopMotion_3.6-15980.app.zip

That version is working as expected so far. Hope this helps anyone in my position.

MacBook Pro Retina 15" (Mid 2014)
OSX 10.10.5
Canon 60D

I’m using a Canon 40D, and I don’t get a live preview as such in v 3.7, but after changing the camera settings to JPEG only, removing the memory card, and switching the camera’s ‘Live View function settings’ to ‘enable’ I can now at least capture a preview image and if I’m happy add the image to the timeline. Not sure if this helps.

Hello! I’ve been going through a half -year long situation close to yours where I can’t get my t2i to work with live view. After working with some Boinx dudes, we finally landed on the solution that worked for me. I am aware that yes it works with 3.6, but for anyone else interested, to get live view to work with 3.7 just click on iStopMotion in the top left hand corner and hold the “option” key. The preferences should turn into debug preferences, and click on it. Check “Ignore whitelisting for Digital Still Cameras,” and then restart. It should work, at least it worked for me

I’m using cannon eos 60D with version 3.7 on el capitan 10.11.2 early 2015 macbook pro… YYYEESS your solution worked for me! Thankyou! Tell the world!

to get live view to work with 3.7 just click on iStopMotion in the top left hand corner and hold the “option” key. The preferences should turn into debug preferences, and click on it. Check “Ignore whitelisting for Digital Still Cameras,” and then restart. It should work, at least it worked for me

Hello! I’m using canon EOS 6D with the new beta 3.7. When I disable the whitelistening for digital still cameras in debug mode my camera works perfect with iStopmotion. So thank you GHB for your great solution.

I get solution of your issue in Canon EOS 60D Manual that get a demo license and use the Still Camera Assitant to find out if your camera works with iStopMotionsoftware. If still camera currently don’t support live preview, it means you have to take a picture with it, before you can see the actual sceen in iStopMotion.

I got iStopmotion to see live view in 60d but after taking one frame the program say communication with camera timed out. After unplugging and etc, it keeps doing the same thing.

Exactly the same problem as David M - after dealing with a few hurdles, I managed to get iStopmotion to link properly with the 40d and to show a picture. The picture saves to the computer (though not where I was expecting) and soon after I receive a message to say communication timed out and unplug. This makes no difference. Any advice?

Seem to be getting it to work now, having taken a while to find and implement all the steps in the absence of an easy guide on this website - Boinx?

  • Remove memory card from camera
  • Set settings to jpg via camera menu
  • enable Live View shoot via camera menu
  • Close down EOS utility on Mac
  • Open Image Capture (in Applications), select camera and set ‘Connecting this camera opens no applications’
  • Enter debug preferences via the iStopMotion top left hand menu by using the Option key
  • Check "Ignore whitelisting for Digital Still Cameras
  • Restart and everything seems to work - so far!

@plasticflame Thanks for working this out and posting your solution. We’ll try to reproduce in our labs. Meanwhile, can anyone confirm that this is working for them?

Unfortunately, the still camera manufacturers don’t see remote control operation as a priority, so it is always a little obscure.