iStopMotion iPad and Remote Camera not working

Hello,

I just bought the iStopMotion app and downloaded the app for my iPhone 4S, but they won’t seem to communicate.

Therefore, I have a couple questions:

  1. When I select Remote Camera, is it normal for the instructions to pop up every time? It seems to flash, and another window appear temporarily, but the only thing on the screen is the instructions.

If this selection is supposed to bring up a camera window, could I suggest there be a status window or something that says “no camera found” or something?

  1. If this selection is supposed to connect to my iPhone, how do I test if it’s working? Both my iPad 2 and my iPhone 4S are on the same high speed wifi network.

Any suggestions would be much appreciated!

Nobody has any suggestions??

if the “Remote Camera…” menu item is shown, the app thinks that there is no remote camera. If it detects a remote camera in the network the menu item gets replaced by the name of the remote camera device.

But what if the iPad app and the iPhone (remote camera) are on the same wireless network yet the “Remote Camera” menu item is still shown?

I installed both apps (iPad and iPhone) this evening, and both devices are on the same wifi network, yet the remote camera is not found.

Thanks for any advice!

Did you launch the iStopCamera app on the iPhone? It should show a “Awaiting connection…” label. Once the iStopMotion app on the iPad established a connection to the iStopCamera app on the iPhone you have to confirm that connection on the iPhone.

I figured out the problem. I have two network configuration settings on my router, one of which is “Guest” and allows no type of sharing–this was the network I was trying to use the apps on. Once I switched to the other config it worked fine. Thanks.

That’s not the problem I’m having. Both my devices are on the same wireless network, but for some reason they don’t see each other.

Hi there,
please try to following (if you own a mac):

  1. get the Bonjour Browser from http://www.tildesoft.com/
  2. launch it
  3. launch the remote cam app on your iPhone
  4. check if the Bonjour Browser lists any services namen “.bxcam._tcp”

If that’s the case check if your iPhone is listed below that service entry.
Otherwise it’s most likely that something’s blocking the Bonjour service announcement.
This might be your router or whatever manages your network.

Other reason might be that your network is IPv6 based or prefers that over IPv4.
Since iStopMotion for iPad does only support the latter this might be another reason.

But first things first. Try the 4 steps mentioned above and let us know about the result.
And well… if you don’t get things to work some additional information (such as what kind of router you are using) might help a lot to solve that issue.

Best.

Yes, my iPhone is showing up in the Bonjour Browser.

Here’s the information from the app:
_bxcam._tcp. - 1
Ron’s iPhone 4Siri
Can’t resolve link-local name
192.168.1.154:51545
[fe80::XXXX:XXXX:XXXX:XXXX]:51545
DeviceName=Ron’s iPhone 4Siri
DeviceIdentifier=[XXXXXXX]
ProtocolVersion=1
RemotelyUsedState=NO
Date=2012-02-37 13:02:04 ±1302

(I purposefully blanked out some of the info with XXXX’s. If this is needed, let me know.)

Please let me know what it might be. I don’t think my router is using IPv6, but I can check into that. (I do not think it is).

Just for comparison’s sake, I ran the same test on my iPad on the same network, and here are the results:

_bxcam._tcp. - 1
Ron’s iPadToo
Can’t resolve link-local name
192.168.1.101:64707
[fe80::XXXX:XXXX:XXXX:XXXX]:64707
DeviceName=Ron’s iPadToo
DeviceIdentifier=[XXXXXXX]
ProtocolVersion=1
RemotelyUsedState=NO
Date=2012-02-37 14:02:68 ±1402

By the way, I went and checked my router, and it doesn’t have a specific setting for IPv6, although apparently it’s compatible with it.

i bet it’s some router configuration issue regarding bonjour or general visibility of wireless devices. and it has nothing to do with IP version or anything. so what’s your router’s model? are you using wireless encryption? if yes… which?

My router is an asus rt-n56u, I don’t see any settings for wireless encryption.

If it was a router problem, wouldn’t the phone not work on wifi?

as far as i could figure your router does not support local dns which is needed for resolving the bonjour services. that’s the reason why the bonjour browser shows the entry “can’t resolve link-local name”. but maybe there’s an option or configuration that keeps the devices from discovering each other. but since i don’t got your router i can’t test it. i’d suggest to test it on another wifi-network/router. it should work on most configurations.
just in case you got another computer or something u could send a ping on… take your mac… go to system preferences -> sharing. on the top you’ll find a text like “Computers on your local network can access your computer at: XXXXXX.local”
now go to the second computer, open the terminal and enter “ping XXXXXX.local”
please let me know what the output is.

oh and regarding your last question… connecting to the wifi and accessing the internet is one thing… finding another device on the local network and connecting to it is another. sorry.

Yes, it supports local dns. I’ve got several servers, printers, an AppleTV, a ps3 and an xbox all sharing files and services through bonjour and PS3 file sharing.

When I ping my server from my laptop using ‘ping mediamini.local’ it works fine.

Maybe I should look into updating the firmware in the router. There seems to be an issue talking to the iPhone 4S only. Everything else works.

OK, I went and reset/upgraded the firmware in my router and now it’s working!

Thanks for all of your help. I wasn’t sure where to turn, or why it was only my iPhone 4S that had the problem.

The weird thing is that CollabraCam was working fine, which is what threw me off. They essentially do the same thing!

I guess there must have been some protocol or other that was being blocked or re-routed…

I’ve got the same problem after the latest update of iStopCamera. I managed to make a connection “once”. Is this also the router problem?

Have you tried restarting your router?

After latest update, istop remote camera don’t want to communicate with my personal hotspot created on my macbook … what about to find some other way of connection between ipad and iphone for capturing outside where is no wi-fi ! what about bluetooth?

I Just register to say that i’m really happy with update of Istopmotion… And also to agree with Libor_G.
I think remote câmera with Bluetooth, would be just perfect. I’m a teacher and i’m think use istopmotion have iPad, iPhone but my school don’t have wireless only wired computers. you have a sollution to This?
Even if you want to make something in playground we can’t! :frowning:

Hope to see the in next istopmotion aps updated soon with Bluetooth!
Regards